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How to create a new database or purge a full SQL (i.e. it has hit the limit of 2G) in Vista IV

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How to create a new database or purge a full SQL (i.e. it has hit the limit of 2G) in Vista IV

Picard Product_Support
‎2018-09-07 01:20 AM

Warning

Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support Services for assistance.

Issue

How to create a new database or purge a full SQL (i.e. it has hit the limit of 2G)

Product Line

TAC Vista

Environment

TAC Vista 4.X

Cause

Log data has filled the 2GB limit of the SQL database.

Resolution

How to purge a full SQL (if you've hit the limit of 2G)

Before deleting the database or creating a new one:

Check the $queues/insertevents and $queues/insertlogvalues folders in the Vista database. This folder may contain "queued" files waiting to be written into the SQL database. If these queues have significant amount of data stored as a result of the SQL being full, you may delete these files if the data is not needed. If the data is needed, it will be written to the new SQL Database when Vista starts.

In some cases, the $queue folders may be so large that even creating a new database won't allow the Vista Server to run. If this is the case and the $queued items are not needed, delete them from their directories. If you find that there is an abundant amount of queued files it may be easier to delete them using DOS.

This can be done by navigating using the "cd" and "cd.." command prompts to c:\TAC\Vista\VistaDb\$queues. There you will find \insertevents and \insertlogvalues. You can clear both directories using the "del" command.

It is recommended to stop the SQL Server and DSS Writer before attempting to delete any queued files. You can stop the SQL Server by double-clicking on the icon in the task bar and choosing to "Stop". You can locate the DSS Writer by right-clicking on My Computer and selecting "Manage". Navigate to "Services and Applications\Services" directory and look for "TAC DSS Writer Service". Right click on this service and select Stop.

If the data is not needed:

Simply go to ...Microsoft SQL Server/MSSQL$TACVISTA/Data and delete the old database. Before doing so, you may need to stop the SQL Server.  Then following steps in "If the data is needed" section below.

If the data is needed:

The simplest way to get a fresh DB is to create one. This is done using TAC Vista SQL Setup which can be downloaded from the Buildings Business Extranet: Global. Make sure that you download the SQL Setup for your Vista product version.
In the Vista SQL Setup program, select your SQL Server - pcname\TACVISTA, Chose Windows Authentication if Vista is managing the Database (recommended in the Vista Install), "Login", enter the name of the database (perhaps "NEWtacdatalog" to be created, and select the login pcname\TACA_pcname, and "Create".

This will create a new database to which you can now point the Vista Server. In Vista Server Setup, under the SQL Tab, change the database to this newly created database, click "OK".

You can keep the old database to export for viewing or if you plan on upgrading to SQL Enterprise and merging the data in the future.

 

NOTE: Sometimes when this is done without first detaching or deleting the database from the SQL, the DSSwriter or TACA user stops working. Detach/Delete the database with SQL Management Studio Express and reinstall the system to solve this.
 

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