Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
In some recent versions of Security Expert there is unexpectedly high data usage on controllers connected by 4G modems.
Product Line
Security Expert
Environment
- Security Expert Server
- SP-C
- 4G Modem
Cause
This can be caused by the Security Expert regularly contacting all controllers to improve status reporting from the event service.
Resolution
If you are experiencing high data usage on metered (low data) connections, you can turn off these regular "check-ins". Be aware that this may increase the chance of controllers dropping offline.
- Stop the Security Expert services.
- In the File Explorer, navigate to the installation directory: ..\Program Files (x86)\Schneider Electric\Security Expert
- Open SecurityExpertSV.exe.config.
Files in this directory require administrator permissions to edit. You may need to open the file as an administrator using an application like Notepad++, or make a copy in a different directory to edit and replace the original.
- Add the following code under the <configuration> node, between </configSections> and <microsoft.scripting>:
<appSettings>
<add key="gx:EnableUnknownStatusMitigation" value="false" />
</appSettings>
- Save the file.
- Open SecurityExpertEvtSvr.exe.config.
- Under the <appSettings> node, add the following code:
<add key="EnableControllerConnectionWatchdog" value="0" />
- Save the file.
- Restart the Security Expert services.