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G3 schedules stop working after Daylight Savings Time (DST) changeover

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G3 schedules stop working after Daylight Savings Time (DST) changeover

Picard Product_Support
‎2018-09-07 06:34 AM

Issue

Some schedules stop operating correctly after Daylight Savings Time (DST) changeover. 

Environment

I/A Series G3, all ENS and ENC with builds 3.5.4, 3.4.53.1, 3.3.31.2, 3.2.23.1 or earlier.

Cause

Any station with a schedule, of any type, with an event set to occur during the "advanced" (missing) hour between 2:00 AM and 3:00 AM on the DST changeover day. The resulting miscalculation of the schedule's "Next Time" or "Next Trigger" time could cause that schedule, or even other schedules in the station, to stop working.

This typically affects downstream logic in the station. In some cases it was observed that the CPU usage on an ENC went up to 100% while calculating invalid next event times.

Examples

  • A station contains a BooleanSchedule with events at 12:00 AM and then again at 2:05 AM daily. At 12 AM the schedule executes normally and attempts to calculate the next event time. On the second Sunday in March the next event time calculates to a time that does not exist due to the DST change. This causes the Java thread that executes all schedules in the station to become tied up attempting to recalculate the time.
  • A station contains a TriggerSchedule that periodically repeats every 15 minutes, with a range passing through the DST changeover time. On the second Sunday in March the next trigger time calculates to a time that does not exist (say, 2:15 AM). Again, this causes the Java thread that executes all schedules to become tied up attempting to recalculate.

Resolution

The solution to this issue is to upgrade the schedule.jar file in the platform to one of the versions below, or later. Files are available from The Exchange Extranet. 

  • Release 3.3.31.2 (Download and extract schedule-3.3.34.1)

If you are using a build that is higher than the above versions then you will not be affected by this issue.

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