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Full Automation Server backup fails - trace log indicates Insufficient_Space_For_Backup

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Full Automation Server backup fails - trace log indicates Insufficient_Space_For_Backup

Guinan RobertAndriolo Guinan
‎2024-07-10 07:25 PM

on ‎2024-07-10 07:25 PM

Warning

Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.


Issue

A full backup immediately fails on the Automation Server.  Performing a configuration-only backup completes successfully.

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation 3.x - first detected
  • Building Operation Automation Server 
  • Building Operation Automation Server Premium (AS-P)
  • Building Automation Server AS-B

Cause

A directory under the DB folder, called tc [TypeCache], within the database of the Automation Server, had grown close to 1 GB in size.  The combination of this with the large TrendDb caused the backup failure with the following message seen in the trace log: 

 

nsp.csc.bar.BarBackupOperation BarBackupOperation Execute failed with: Internal Server Error: Insufficient_Space_For_Backup (0x80008) in module Bar_Manager(51). "/<servername>": Insufficient space for backup, XXXXXXXXX bytes estimated for new backup but only XXXXX available

 

This tc directory contains types fetched from other servers that are used in runtime. These are loaded either from the local database or the tc directory. If a type for another server is not found in the tc directory when accessed, it will first be fetched from that server.

 

There may be other reasons for the backup failure, presenting this Insufficient_Space_For_Backup message in the trace.log. Clearing this Type Cache does not adversely affect the controller and can be cleared as the first step to see if this will allow the full backup to occur. 

 

The issue has only been seen in Building Operation 3.x, if the issue is presented in a later revision or you continue to have failures, then contact your local support and reference this article.    

Resolution

To clear the Type Cache contents, follow these steps:

  1. Navigate to the RuntimeDBManager object under /System/Modules/RuntimeDBManager/
  2. Right-click on the TypeCache object.
  3. Select Type Cache
  4. Clear All
    TypeCacheClearing.png
  5. Attempt a full backup of the server again.  If failures continue to concur, then contact your local support
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