Issue
Filemaster is Full SQL 2005 and Equalized Client is SQL Express fails to equalize.
Environment
- Full SQL 2005 for the Filemaster
- SQL Express for the Equalized Client
- 2.31 version of TAC I/NET Seven
- 2.4x version of TAC I/NET Seven
Cause
SQL Express doesn't start equalization services automatically.
Resolution
The Equalized Client refused to replicate the database with the Filemaster. Equalization is not succeeding even though the little icon may say it is equalized. Filemaster shows pending. Start I/NET and check the host passwords to see if equalization has taken place.
- The following steps will cause equalization to take place:
- Restart the pc to ensure there isn't a program hanging in the memory.
- Demote Equalized Client to Stand Alone.
- Exit I/NET and I/O Server
- Go to Start/Run/CMD
- Maneuver to the C:\Program Files\Inet Seven folder and type the following:
- ineteqzmerge /unregserver press the Enter key
- ineteqzmerge /service press the Enter key
- Now go to Services by selecting My Computer/Manage/Services and look for the Service running called InetEQZMerge and start the service and select Automatic.
- Now you should promote the I/NET workstation to Equalized Client ensuring you put the Filemaster Name rather than IP address.
- The snapshot will be delivered to the Equalized Client. After equalization you may need to shut down I/Net and the I/O Server one last time and then restart I/NET Seven.
- Now return to Services by selecting My Computer/Manage/Services and look for the Service running called InetEQZMerge where you should STOP then START the service again.
One way to test equalization from Filemaster to Equalized Client: in I/NET Seven under Edit/Host Computer/Passwords add a user/password. Check the other computer to see if the database replicated the new user/password and Vice Versa.
If ineteqzmerge is already running as a service. Try stopping and starting the service.