Issue
I have a UNC-520-2 running Niagara 522 that is connected on a local network, with internet access. Alarm emails are not sent and I get the following error message:
ERROR: Cannot send mail [/Dundee_2StClair/services/MailService]
javax.mail.SendFailedException: Sending failed;
nested exception is:
javax.mail.MessagingException: Unknown SMTP host: smtp.broadband.rogers.com ;
nested exception is:
java.net.UnknownHostException
at javax.mail.Transport.send0 (bytecode 611)
at javax.mail.Transport.send (bytecode 9)
at tridium.services.MailService.sendImpl (bytecode 29)
at tridium.services.MailService.run (bytecode 44)
at java.lang.Thread.run (line 5)
Environment
I/A Series R2 UNC (520, 410 or JACE-NSX/NXT)
Cause
Mail server address defined by name (smtp.broadband.rogers.com)
No DNS server addresses defined in the IP address configuration of the UNC
Resolution
The error message indicates that there was no response from the SMTP server address specified. In this case, since the SMTP server is specified by name instead of its IP address, it is necessary to provide one or more DNS (Domain Name Service) servers that can be used to resolve the address to its associated IP address.
To enter one or more DNS addresses, access the UNC via the Admin Tool and select the Network Settings tab. On the lower part of the Network Settings screen, click the [Add] button and enter the IP address of the DNS server in the table. Repeat this step if additional DNS servers are to be added. Click the [Apply] to save the settings. Here is what the screen looks like when two public DNS server addresses have been entered.