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Error: LNS #108 lcaErrCantConnectToServer, Lca : Cannot connect to the requested TCP-based LNS Server. (Subsystem: LNS, #108)

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Error: LNS #108 lcaErrCantConnectToServer, Lca : Cannot connect to the requested TCP-based LNS Server. (Subsystem: LNS, #108)

Picard Product_Support
‎2018-09-06 02:21 PM

Issue

The remote client fails to connect to the LNS Server.

Environment

LonMaker
NL220
Vista
LNS

Cause

When using LNS 3.8 to make a client/server application : - LNS server is launched on the server - when opening the database on the client, you get the error. 

 It is a port problem.

Resolution

Lightweight clients use port 2540 to talk to the server and LNS applications also require ports 6001 and 6002. You can check the port usage on your PC by launching netstat -a in a command prompt ; you will get the list of the ports used.

netstat -bn will also give you a list of ports being used.  It can occur if the LNS Server has not been started on the server PC and the client attempts to connect.  Or if the network is not connected and onnet ready to receive remote clients.

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