Issue
Echelon LON interface card installed in computer is not recognized by the LonWorks Plug and Play utility nor by the I/A Series software installed on the computer.
Environment
- LON interface card
- PC
Cause
This problem is caused by not installing the Echelon driver for the PCLTA-10 / PCLTA-20 / PCLTA-21 / PCC-10 card before installing the card into the computer.
Resolution
Steps 14-20 of this procedure can be used to test the PCC-10 lon card and driver if the proper driver is believed to be installed.
Before attempting to reinstall the driver, verify that this Echelon file is available: "OpenLDV340.exe", "153-0117-01C.zip" or "PCLTA21 Win2k XP.exe". If the .zip version is available, extract the .exe file from that .zip file, to the desktop.
To correct the problem and install the proper driver, use the following procedure.
- Open the Windows Control Panel and select SYSTEM then select the hardware tab.
- Select the Device Manager button.
- Check to see if the Echelon card is already installed -- look for the entry "Lonworks Network Interface" and click on that entry to open it then select the "Lonworks xxxx Network Interface" choice that was just displayed. (then continue with step 5 below.)
- If the Lonworks Network Interface was not shown, look for an entry with a yellow question mark -- a Lonworks entry so marked should be found. Select that entry.
- Right click on the Lonworks entry just selected and select "Uninstall…". Follow the prompts to uninstall the driver.
- Shut down Windows and power down the computer then remove the Echelon card from the computer.
- Power up the computer.
- Log into the computer using an account with full administrative rights. Run the Lonworks driver application file ("OpenLDV340.exe", "153-0117-01C.zip" or "PCLTA21 Win2k XP.exe") that was downloaded and extracted. This installs the driver into Windows.
- After the installation completes, close the prompt indicating that a reboot is required then shut down Windows and power down the computer.
- Reinstall the LON interface card.
- Power up the computer and log into Windows.
- The system will indicate that new hardware has been installed and will attempt to locate a driver for the new hardware. Allow the system to install the card driver.
- When the hardware installation wizard finishes, it may indicate that the computer must be restarted before attempting to use the new hardware. If so prompted, shut down windows and restart the computer, logging in again as an administrative user.
- Open the Windows Control Panel and select (double click) the "Lonworks Plug 'n Play" entry.
- Verify that the device selected is LON1.
- If not already selected, specify the NSIxxx application in the NI Application selection box.
- Click the "Diagnostics" button.
- Click the "Reset" button then click the "Restart" button. Click "Yes" to reset the card to its boot state.
- Click the "Test" button and verify that no errors are indicated.
- Click the "OK" button to leave the Diagnostics screen then click "OK" on the Lonworks Plug 'n Play screen to save the configuration information and exit the utility.
The Echelon LON Interface Card is now ready to use.