Issue
EBO system was in sync with Building Advisor Portal and is now not.
Product Line
EcoStruxure Building Operation, EcoStruxure Building Advisor
Environment
- Building Operation Building Advisor Portal
- Building Operation Enterprise Server
- Building Operation Automation Server
Cause
System ID changed and no longer matches in Building Advisor Portal.
Resolution
- Check EBO Server Trace Log for nsp.pin.Cloud records and there should be one that shows "SystemId". Here is an example:
2023-11-19 12:37:30.437 [320] nsp.pin.Cloud.DspInterface Sending notification {"ProtocolVersion": "1.0", "NotificationType": "TimeSeries", "IotDeviceId": "urn:dev:ops:sebms-sbo-es-fb6b2834ba4749d89cdad333c12704a3", "SystemId": "4ba3db45-0235-7146-981a-c81dc08e39bf", "GeneratedAt": "2023-11-19T12:37:30.0437Z", "GeneratedBy": "SBO 3.2.4.22","Operation": "Update","TimeSeries": [{"TimeSeriesId": "d8e6b6fc-a472-4285-a56d-2d3e4a6915e1","Samples": [{"Timestamp": "2023-11-19T12:37:30.0437Z","Value": "Unknown [null]","Unit": "0x10001","Status": 20}]}]} 2023-11-19 12:37:30.437 [320] nsp.pin.Cloud.DspInterfaceReal edgeAgent_sendMessage: {"ProtocolVersion": "1.0", "NotificationType": "TimeSeries", "IotDeviceId": "urn:dev:ops:sebms-sbo-es-fb6b2834ba4749d89cdad333c12704a3", "SystemId": "4ba3db45-0235-7146-981a-c81dc08e39bf", "GeneratedAt": "2023-11-19T12:37:30.0437Z", "GeneratedBy": "SBO 3.2.4.22","Operation": "Update","TimeSeries": [{"TimeSeriesId": "d8e6b6fc-a472-4285-a56d-2d3e4a6915e1","Samples": [{"Timestamp": "2023-11-19T12:37:30.0437Z","Value": "Unknown [null]","Unit": "0x10001","Status": 20}]}]} (retCode = 0)
- In Building Advisor Portal, check the BMS System Identifier to ensure it is the same and update as needed.
- In this case, d057cfba-9fc0-11e4-a62a-3417ebbed129 needed to be updated to 4ba3db45-0235-7146-981a-c81dc08e39bf