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Do not install N4.11 or 4.12 to a JACE-8000 or Edge 10 running 4.10U7 or later

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Do not install N4.11 or 4.12 to a JACE-8000 or Edge 10 running 4.10U7 or later

Guinan RandyDavis Guinan
‎2024-10-15 09:09 AM

Warning

Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.

Issue

Upgrading a JACE-8000 or Edge-10 from 4.10U7 to 4.11 or 4.12 will prevent Niagara Daemon from starting.  You will be unable to connect via Workbench or Browser.

Product Line

TAC IA Series

Environment

  • I/A Series N4 Jace 8000
  • Tridium Edge 10

Cause

The software in builds 4.10u7 and later LTS builds (4.10u8, 4.10u9, 4.10u10) was released after 4.11 and 4.12 reached EOL.   4.10u7 contains a newer signing key that is not recognized by 4.11 and 4.12.

Resolution

When upgrading JACE-8000 and/or Edge 10 running 4.10 LTS builds 4.10u7 and later, please skip over 4.11 and 4.12 and instead upgrade to 4.13u3 or newer. Alternatively, you may apply the dist that reverts JACE-8000 to clean 4.9u1 state, or for Edge-10, the dist that reverts it to clean 4.7 state. You can then install 4.11u2 or 4.12u2, if that's the version you have to use. 

  • If you've already attempted the commissioning operation and bricked a device, and have backups, you can connect to the debug port and use the factory reset process per the documentation. 
    • For Edge 10, consult the section titled Factory Default Recovery  in the Niagara Edge 10 Install and Startup Guide. 
    • For JACE-8000, consult the section titled Restoring factory defaults  in the JACE-8000 Backup and Restore Guide.
  • If you are lacking any backups for the host, then before performing the factory reset, you should enable SSH/SFTP via the debug port, and then copy out the Station files using Filezilla or WinSCP or equivalent. 
    • Reach out to your support channel if you have difficulty finding the location of station files. Typically, the files will be in a subfolder of /home/niagara/stations. The config.bog file will be keyring encrypted, and you'll have to reset it using the Bog File Protection Tool. See Editing the .bog file passphrase offline in the Niagara Platform Guide  for details on using the Bog File Protection Tool. 
    • For details on using the debug port on JACE-8000, see Debug port  in the JACE-8000 Install and Startup Guide. 
    • For details on using the debug port on Edge-10, see Connecting to the debug system shell  in the Niagara Edge 10 Install and Startup Guide.
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