Issue
A Niagara R2 Enterprise Server station is extremely slow in starting, and there are hundreds of alarms. Is there a way to delete all the alarms?
Product Line
TAC IA Series
Environment
Niagara R2 Enterprise Server
Cause
Storing unwanted various alarms can cause the station to boot slow.
Resolution
The alarms can be deleted in two ways.
The first method is to delete the app folder under the station directory. The entire historical content of the station will be deleted. This includes archived trends, alarms, and events. Follow the steps below to delete the app folder. Deleting the app folder to clear the contents of the database only applies to a Cloudscape installation.
- Open windows explorer and navigate to Niagara\station\[station name]\app
- Delete or move the app folder
- Restart the station
The second method, is to use the appdb/queryForm servlet to selectively remove data from each table including alarms. This is done by using a web browser. Depending on the size of the database this method may take a substantial amount of time. Follow the steps below to delete data from the database by using SQL queries.
- Open a web browser and navigate to http://[ipaddress]/appdb/queryForm
- In the form, enter the following query - delete from event.eventhistory This will delete all history data in this table. For further information refer to the SQL_Tutorial\QueryExamples_10_6_04.pdf