Issue
Data not showing in a single row on the Trend Log Comparison Report
Creating Custom Reports
Environment
Report Builder 3.0
Struxureware Building Operation WebReports
Cause
Trend sample data is stored in the Reports Server at a resolution of less than 1 second. In some cases the user wants to compare data in showing less resolution than what is in stored in the database.
Resolution
- Open Microsoft Report Builder and Edit the existing Trend Log Comparison Report. You can get detailed instructions on how to perform this task on the online help guide.
-
Scroll to the bottom and select the DateTimeStamp Field in the Second Tablix object.
-
Click on the drop down menu in the Row Groups pane and select Group Properties
-
On the General Tab, click on the Fx button
-
Change the Expression to say: =FORMAT(Fields!DateTimeStamp.Value, "dd MM yyyy hh:mm")
-
Repeat this for the Sorting Tab. Enter the same Expresssion. =FORMAT(Fields!DateTimeStamp.Value, "dd MM yyyy hh:mm")
- Click OK to save changes.
-
Right click on the DateTimeStamp TextBox and select Text Box Properties.
-
In the Number tab, change the default format to the desired display format
- Perform a Save AS to ensure you do not overwrite the factory supplied report.
- Follow the instructions on web help to allow the modified report to be used in WebReports.