Issue
Licenses are becoming damaged repeatedly over time and/or licenses are going in to a disabled state.
Product Line
EcoStruxure Building Operation, TAC Vista
Environment
- SmartStruxure
- License Administrator
- Virtual Machine
Cause
Damaged Licenses: If the license server / license administrator is installed on a virtual machine, the common reason for damaged licenses is that the MAC address of the virtual machine is not set to be static. Every time the MAC address changes, the license will become damaged.
Disabled Licenses: This is usually caused when the license fails to complete a process such as a return or repair. This could be due to an intermittent internet connection or the process timed out while trying to communicate with the license server.
Resolution
Repair License with License Administrator
The first step to take with a damaged or disabled license is to use the repair function in license administrator. Follow the steps from WebHelp topic Repairing an EcoStruxure Building Operation Software License. If the repair function does not work, then the license server will need to be reset.
Reset License Server (Unable to Repair License)
Below are the steps to remove the damage or disabled licenses before reactivating the permanent licenses again:
- Put a SBO demo license on the site to get it back up and running right away.
- Locate the Entitlement ID and/or activation ID of the impacted licenses. Open a case with your local BMS support group and provide them this information. This information will be used to release the licenses to prepare them to be rehosted.
- There are then two potential methods to reset the license server:
- Download and run the SBO License Server Reset tool from the Community
- Manually reset the License Server
- Stop the License Server.
- In the License Server application folder, remove all files:
- File path for Windows 7, Windows 8.1, and WIndow 10: \ProgramData\FLEXnet
- File path for Windows Server 2008 and Windows Server 2012: \ProgramData\FLEXnet
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- Start the License Server
- Reactivate the returned network licenses.
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Note: When you reactivate all returned network license, new License Server .data files are created together with the activation of the first license. For more detail, reference WebHelp: Resetting the License Server.