Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
Continuum cardholders with PINs that start with "0" (zero) are not importing into Security Expert using Data Sync Tool
Product Line
EcoStruxure Security Expert
Environment
- Security Expert
- Continuum Transition
Cause
Due to the database's configuration, Any PIN in Continuum starting with a "0" (zero) will be truncated. When DSS runs, the personnel (cardholders) with truncated PINs will be rejected by the PIN length restriction and sent to the error folder.
Example: If you have a Continuum site with four-digit PINs and a PIN is entered into Continuum as 0123, will be truncated to 123 in Continuum (Continuum ignores the zero at the reader keypad as well). If you have SX configured for a 4-digit PIN length. This cardholder will not import.
Resolution
Option 1:
Identify the truncated PINs in the Continuum database by running a query and have those users' PINs updated before running CTT and DSS. This should be done as part of your system cleanup before transitioning.
Option 2:
If you have a minimum PIN length configured in Security Expert, Stop DSS if running.
Go to Global|Sites|Site Defaults tab and scroll to Site security enhancements. Set minimum PIN length to "0". Save changes.
Start DSS. You will still have to correct any PIN that are less than the site minimum before
enabling this feature again.
Note: This option should only be chosen for a one-time sync. If you are running a continuous/lengthy transition, you should use Option 1. Otherwise, you will run into this problem again.