Issue
Following a successful configuration of the Continuum Transition Tool (CTT) it has been noted that some ongoing changes in Continuum do not seem to then be migrated through to the Security Expert database.
Product Line
Andover Continuum
Security Expert
Environment
- Continuum Transition Tool
- Security Expert Data Sync
Cause
It would appear that on occasion, some changes made to Continuum Areas after the initial CTT Transition is completed, fail to be exported from the Continuum DB by the CTT in its periodic update, This can be verified by examining the actual CSV output and seeing that certain known changes to Areas are simply not present. The actual Security Expert Data Sync is working correctly but if the changes are not exported by the CTT then they cannot then be imported by the Data Sync Service
Resolution
Although this is not currently resolved, it is documented as a limitation of the Andover Continuum System.
Page 21 of the Transition Guide Security Expert - Continuum Database - Transition Quick Start Guide states that the Last Changed field of an Area object is only updated if the object is edited in a specific way.
Since the CTT uses the Last Change field to decide what new object changes need to be exported, this legacy issue in Continuum directly affects the update to Security Expert if the changes are not made as advised above.