Issue
What third party Card Printers are supported for use with Security Expert?
Product Line
Security Expert
Environment
- Security Expert Client
- Third-party Card Printers
Cause
There is no list of supported printers as there are too many devices to test. Some testing has been done as listed in the resolution below.
If an issue should come up with a card printer then raise a support case and they will assist where possible and offer suggestions regarding the update of printer drivers, windows and printer preferences, etc. If necessary and the customer cannot resolve an issue then they may wish to supply the particular printer for testing and validation.
Resolution
There is currently no list of supported Card Printers, the following two printers have been tested by Engineering with Security Expert:
- Datacard SD260
- Datacard CD800
Indications that the HID Fargo HDP8500 and Fargo DTC4500e also work with Security Expert.
In general, if the card printer presents itself in Windows as an XPS printer, then the printer should work with the Security Expert Client. This may require a printer driver to be downloaded and installed from the printer manufacturer for the printer to show up in the "Printers and Scanners" list
in Windows.
Note: R&D has indicated that currently (12/19/2024) there is no list of printers or documentation as to what specific features or configurations are supported by each printer above.
Some functionality in Security Expert and within printer drivers allows the selection of landscape or portrait orientation. However, hopper selections are not currently supported. Printer testing was done with standard iso card printing using landscape and portrait using a single hopper. Any other requirements outside the above will rest fully with the partner/branch/customer to test and confirm it works as needed.
If the testing doesn't support the required specifications, a feature request needs to be submitted, evaluated, and potentially implemented in a future version of Security Expert per the LOB.