Issue
- How can I troubleshoot a communication issue with the Smart Connector.
- Is there a log available within the AS or ES that shows the Smart Connector communication.
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Workstation
- Building Operation Automation Server
- Building Operation Enterprise Server
Cause
When troubleshooting Smart Connector issues in an AS or ES it can be helpful to see the communication between the Server and the Smart Connector device to help identify this issue. The trace log within both server types is available and is configured as described below in the resolution.
Resolution
- Open Workstation and navigate to [AS/ES name]/System/Modules/Trace/Loggers/nsp/nsp.csc/nsp.csc.CWSServer.
- Right-click "nsp.csc.CWSServer" and choose Properties.
- Under Level, change from "Information" to "Trace", then click ok.
- Let it run a few minutes. If there are some user input needed to recreate the Smart Connector issue, then perform these steps now.
- Retrieve the log by right-clicking [AS/ES name]/System/Modules/Trace/TraceSettings and choose Trace settings->Get trace log.
- Save the log file.
- Once debugging is complete remember to change log level back to "Information" (reverse of step 3).
Note: If the ES or AS is reset, i.e. cold started or warm started, the log level will return to 'Information', so if further increased logging is required, the procedure will need to be repeated.
Note2: This option is only availabe for EBO version 6.02 and onwards