Issue
How can I troubleshoot communication issues between SEAL app and EBO server?
Does the SEAL app provide a detailed log for troubleshooting communication issues between the app and the EBO server?
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Automation Server
- Building Operation Enterprise Server
- Ecostruxure SEAL
Cause
When troubleshooting SEAL communications issues to an EBO server, it may be helpful to get deeper information about the communication between the server and the SEAL application.
To do this the following lines can be added to the appsettings.json application settings file as described below in the resolution
Resolution
-
Browse to C:\Program Files\Schneider Electric\SEAL
-
Open the file appsettings.json. Depending on your user rights, you may need to copy and edit this file in another folder
-
Go to line 26. After the closing brace }, enter a comma ,
-
Paste the following:
"Serilog": {
"Using": [
"Serilog.Sinks.File"
],
"MinimumLevel": {
"Default": "Information",
"Override": {
"Microsoft": "Warning",
"Microsoft.Hosting.Lifetime": "Information",
"SE.SEAL": "Debug",
"SE.SEAL.Web.Auth": "Verbose"
}
},
"WriteTo": [
{
"Name": "File",
"Args": {
"path": "%LOCALAPPDATA%/SEAL/logs/SEAL.txt",
"rollingInterval": "Day",
"shared": true
}
}
],
"Enrich": [
"FromLogContext"
]
}
- Save the file.
- Try logging into the SEAL app and connecting to the EBO server
- Save the log found under: %LOCALAPPDATA%/SEAL/logs/SEAL.txt
- Restore the appsettings.json file to its original state.
Attached to this article is a ready-made file for use.
- Move the original file to another folder
- Place the attached file in C:\Program Files\Schneider Electric\SEAL
- After saving the logs, delete the attached file
- Move the original file back to its original location
In addition to this, it is always recommended to take an event view - Application log