Warning
Electrostatic Discharge Required: Always discharge static electricity from your person by touching metal prior to handling any hardware. Failure to do so may result in damage to devices.
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
Data cannot be seen on Partner Portal for RS485 devices.
Product Line
EcoStruxure Building Activate
Environment
- EcoStruxure Building Activate Flex Server
- EcoStruxure Building Activate Partner Portal
Cause
Data for the Modbus devices can be seen on third-party tools like Modscan but not on the Partner Portal.
Resolution
Follow the steps below if the Flex Server RS485 port is not sending any data:
- Ensure connections are made according to the installation instructions.
- Verify the correct port is configured.
- Double-check that the connections are not reversed.
- Inspect for any loose wires.
- Confirm the Modbus/BACnet ID is correct.
- Verify the baud rate configured for the end device.
- Check for any loose wire strands shorting on the bus or to the ground.
- Ensure no Modbus device is connected to the BACnet bus, or vice-versa.
- Confirm the number of devices in the loop matches the specifications in the installation instructions.
- Check if the loading of devices causes significant changes in resistance.
- Do not connect more than two resistors on a single bus.
- Ensure cables used are as per the specifications in the installation instructions.