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Basic setup tips for the I/A Series G3 (Niagara) GCM driver, tacGcm.

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Basic setup tips for the I/A Series G3 (Niagara) GCM driver, tacGcm.

Picard Product_Support
‎2018-09-10 04:57 AM

Issue

Basic setup tips for the I/A Series G3 (Niagara) GCM driver, tacGcm.

Environment

ENC-520-2
ENC-410
I/A Series G3 GCM driver, tacGcm
Network 8000 GCM (GCM-84000 series, GCM-86000 series)

Cause

This article is a work in progress. The intent is to provide information proven to be helpful, and add to it as we learn more.

Resolution

G3 GCM (tacGcm) driver setup basics:

Serial communications between the UNC/ENC and GCM-84000 series must use GCM Port 2.
The GCM-84000 series Port 1 is not buffered and cannot be used for network communications.

The GCM participates on a network that includes 27 other GCMs. The recommendation is one UNC/ENC per GCM and to share data between the UNC/ENC devices with peer to peer links. The baud rate on the serial port is limited to 9600 and all communications (UNC/ENC, ASD, LCM, GCM to GCM, MMI, etc.) all share the same internal GCM communications buffers. It is this buffer on the GCM-84000 series that can easily be overwhelmed.


Use Poll On Demand (POD) containers (G3 uses proxy points without history or alarm extensions) where possible.

To optimize the use of the communications bandwidth, route alarms to the GCM serial port used by the GCM driver only as needed. Exceptions and Trend reports (and other reports generated by the GCM hardware) should never be routed to this port, as this data is not used and will utilize precious bandwidth.

Only one HMI should be connected and active on the network. 
Issues may occur when using the UNC / ENC GCM driver to poll a GCM network while simultaneously polling the same system with another HMI (e.g. Host, InVue, UltiVist, Signal, etc.).

GCM-84000 series and ENC communications (tuning)

Communications can greatly affect GCM operation and stability. As  indicated previously, all communications is process by a common communications buffer further affecting the GCM system RAM.

Log into the GCM and review the current SYSRAM. It is recommended the GCM-84000 System RAM is stable and operating above 18K bytes. Low RAM will cause the GCM to appear to lockup, stop processing messages, and even reset.

Review delta times for the blocks. Check the DETIM (Delta Time) attribute of a random sampling of blocks, especially those that have low update times assigned or involve device communications. Update times for blocks such as SNET, RNET, SGCM, RGCM, SLCM, and RLCM should especially be reviewed and increased as needed. These blocks default to 5 seconds and should be increased to a reasonable timeframe (e.g. 30 seconds).

For other blocks, if the DETIM value is greater than the UPTIM value by more than a couple of seconds, the system may potentially be experiencing system throughput problems. This should be monitored as changes are made to the system to determine if it improves.

Adjustment of update times should also be done in the other GCMs that may be requesting data via global type blocks.

If the RAM has not stabilized and is below 18K bytes, decrease the GCM driver maxMessages from 5 towards 3 or 2. This controls the number of messages requested simultaneously from the ENC

Note: DETIM block output is normally hidden.
In order to see it, login to the GCM as user = BCFLD, password changes every day. Contact PSS - Rockford for a current password.

Verify  that the "Write on Start", "Write on Up", and "Write on Enabled" are all set = false in the default Tuning Policy of the GCM Network. 


 

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