Issue
"An unexpected error occurred" shown while downloading a LonWorks device through a Xenta Server
Product Line
TAC Vista
Environment
- TAC Xenta Server (511, 527, 555, 701, 711, 721, 731, 913)
- TAC XBuilder
- TAC Vista Server
Cause
There are a couple of reasons that you can get this error message.
One is that SSL 3.0 is not enabled in Internet Options for the Windows user running TAC Vista Server. This will keep Vista Server from being able to download a Xenta controller using a Xenta Server. It will also not let you download and XBuilder project to the Xenta Server, and you can not connect to the browser of the Xenta Server using Internet Explorer.
The other reason could be, that while running Vista Server as a service, the Windows account running the service is Local System and that this account does not have SSL 3.0 enabled.
This could also occur if you have enabled "System cryptology: Use FIPS compliant algorithms for encrypting, hashing and signing" in the local policy setting.
Resolution
Enabling SSL 3.0
- Go to Control Panel and open Internet Options.
- Choose the Advanced tab and scroll to the bottom of the Settings list.
- Near the bottom you will see Use SSL 3.0. Make sure the Use SSL 3.0 box is checked.
Configuring the Windows account running TAC Vista Server
- Download the TAC Vista Run Mode tool and run it.
- Under the Service Logon section choose Local User for the Logon Type, select or write the Windows user name and password.
- It has to be the account you are currently logged in with, or another user having enabled SSL 3.0 and has administration rights.
- Restart the service.
Check the local security policy for FIPS
- Open Control Panel - Administrative Tools -Local Security Policy (or type secpol.msc in Start-->run)
- Go to Local Policies-Security Options
- Find System cryptology: Use FIPS compliant algorithms for encrypting, hashing and signing
- Change to disable, apply-OK
- Restart XBuilder