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An error occurred while installing DSS: Cannot Start Service

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An error occurred while installing DSS: Cannot Start Service

Picard Product_Support
‎2018-09-06 03:04 PM

Issue

An error occurred while installing DSS: Cannot Start Service

Product Line

TAC Vista

Environment

  • DSS
  • Vista Installation

Cause

This error can be found when installing Vista 4.3.x or higher after selecting Vista Administration of the SQL database.

In the Application Event Log you will have an error stating the following:

Cannot start service DSSWriterService on Computer '.'.
--Stacktrace-
at System.ServiceProcess.ServiceController.Start(String[[,args)
at System.ServiceProcess.ServiceController.Start()
at TAC.DSS.Install.ServiceInstallTask.Install()
--End of stacktrace--

The reason this is happening is because when you selected to have Vista Administrate your SQL database it created local PC accounts (TACA_PCNAME and TACM_PCNAME). The TACA_PCNAME account is used to start the TAC DSS Writer Service and that account does not have access to the file to launch it.

The access problems are typically caused by installing Vista on Windows Server 2003 and the "Authenticated Users" group has been removed from the User group on the PC.

Resolution

  1. Click "Yes" at the install prompt and let the installation complete.
  2. Right Click on My Computer, and select "Manage".
  3. Navigate to Groups found in System Tools\Local Users and Groups.
  4. Double Click the "Users" group.
  5. Click the "Add" button.
  6. Click the "Locations" button and select your PC at the top of the list and then "OK".
  7. Type in TACA_PCNAME and click "OK".

Note: This error should only occur if you have a non default security scheme on the network or PC. You should consult the IT department to make sure the TACA_PCNAME account will not be removed from the User group which will cause this problem to return.

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