Issue
All Controllers appear offline with any associated I/O showing a status of “Unknown”. The Security Expert Event Service's memory usage builds up until it gets close to 2GB when the controllers go offline. Restarting the Security Expert Event Service brings the controllers back online. After a period of time the issue re-occurs and controllers again appear offline.
Product Line
EcoStruxure Security Expert
Environment
Security Expert
Cause
A potential memory leak in the Event Service would cause the service to stop working resulting in controllers appearing offline.
Resolution
1. Upgrade to Security Expert version 4.3.370.1 or greater as discussed in known issue.
2. A potential workaround to mitigate the frequency of the problem is to disable the Event service from using MSMQ. As long as there are no site integrations using MSMQ then this option can be disabled in the Event Service Config file.
Go to ..\Program Files (x86)\Schneider Electric\Security Expert and edit the SecurityExpertEvtSvr.exe.config file. Search for the MSMQ key
<add key="MSMQ" value="1" />
and replace it with the following.
<add key="MSMQ" value="0" />