Issue
After replacing an older revision MNL controller with a new one, WorkPlace Tech is unable to download the existing application file into the new controller reporting an error "The selected device is Invensys IA(x) ... controller, the application requires Invensys IA(y) ... controller". In this error message the controller type info (...) will be the same in both parts of the message but the IA(x) and IA(y) part of the message is different.
Environment
MNL-50
MNL-100
MNL-110,
MNL-130,
MNL-150,
MNL-200,
MNL-Vx
Cause
Replacement controller is of the same type but of a different version.
This issue occurs any time a version 2 controller is replaced with a version 3 controller.
for example, this error will occur if a MNL-V2RV2 controller is replaced by the newer version, MNL-V2RV3.
Resolution
- Open application in the WorkPlace Tech Tool.
- Open the Hardware Wizard and click the [Back] button to open the Controller Selection page.
- When the Controller Selection page has been opened, you will note that the [Older] tab has been displayed with the existing controller type displayed.
- Select the tab corresponding to the controller type, for example if replacing a MNL-V2RV2 controller, select the MNL-VAV tab.
- Select the model of the replacement controller, for example when replacing a MNL-V2RV2, the replacement is the MN-V2 [MNL-V2RV3].
- Click the [Next] button to complete the selection of the replacement controller type then click the [Finish] button to close the Hardware Wizard.
- Recompile the application and download it to the replacement controller.
If the controller is part of a LON network that has been commissioned by a LON Network Management tool, it will be necessary to replace the existing device object and commission the new controller.