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Adding Enterprise Server to Enterprise Central fails with Error - Object Does not exist Domain: Data Access

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Adding Enterprise Server to Enterprise Central fails with Error - Object Does not exist Domain: Data Access

Guinan RobertAndriolo Guinan
‎2022-03-15 08:23 PM

on ‎2022-03-15 08:23 PM

 

Issue

When adding an Enterprise Server (ES) to Enterprise Central (EC), the process fails with Error - Object Does not exist Domain: Data Access.

Details: Modules: Connect Plugin Module Code 73
Error-DomainDataAccess.png

Trace log shows the following text:

nsp.csc.csm.ChangeSetTransaction Rollback due to Data Access Error: Object_Does_Not_Exist (0x40004) in module Connect_Plugin(73), moduleCode=73. ""
nsp.csc.cspclient.AddServerCommandPassThrough Execute: Data Access Error: Object_Does_Not_Exist (0x40004) in module Connect_Plugin(73), moduleCode=73. ""
nsp.csc.cspclient.ConnectionPool Terminating. GetConnection aborted [IP Address: port#]

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation Enterprise Central 
  • Building Operation Enterprise Server 
  • Registered System

Cause

In this instance, the ES added to the EC is currently registered.  Registered Servers can only be the parent server and therefore cannot be added to a non-registered system or a different system.  Parent servers can only be registered, and any sub-servers inherit this registration from the Parent sever.   

Resolution

The registration should always be on the parent server.

To remove the registration from the ES, the SystemID needs resetting as per the following procedure: 

Resetting the System ID

Once reset, the system is no longer registered, and adding the ES to the EC will be successful. 

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