Issue
An application created using WorkPlace Tech was working properly when created. As many additional changes have been made to the application, unchanged portions of the application that were working no longer work correctly.
Some observed examples of this issue are as follows:
- MNB-1000 application that includes the ADI interface worked when the first few ADI points were linked but after moving the application to another computer and linking the remaining ADI points, the ADI interface no longer worked.
- Hardware I/O points are not being properly handled after editing, compiling and downloading the application to the target controller. This application was originally created on a different computer but with the same version of the WPT software.
- When downloading an application to the controller, WorkPlace Tech reports "Unknown error" but no errors were reported when compiling the application.
- Connecting lines that are a valid connection but are displayed as a red line.
- Application not correctly using configuration as specified by Hardware Wizard even though Hardware Wizard has been run and appeared to properly configure the application.
- Some internal program objects do not appear to operate as documented.
Environment
WorkPlace Tech Tool version 5.x.x
Cause
If the application data stored in the WorkPlace Tech application drawing file (vsd file) becomes corrupted, the application continues to compile correctly but does not operate. This corruption is not observed on the drawing itself. The application data and drawing data are independent of each other within the Visio file. In some cases, an application created in WPT 4.x may contain application database information that is not correctly recognized by WPT 5.x.x.
Resolution
After opening the application in the WorkPlace Tech Tool software, run the "Rebuild Application" function to rebuild the internal representation of the application database. The location of the "Rebuild Application" function in the Visio menu varies depending on the version of Visio that is running the WorkPlace Tech Tool software. When starting the Rebuild function, a Windows WARNING dialog box is displayed. To accept the displayed conditions of the Application Rebuild function, click the [Yes] button. Further information on the information displayed in the dialog box is shown in the NOTE and Warning paragraphs, below.
If using a version of Visio prior to Visio-2010, i.e., no ribbon bar, and WorkPlace Tech Tool version 5.6 or 5.7.x, the "Rebuild Application" function is found under the "Application" menu.
If using Visio-2010 with WorkPlace Tech Tool version 5.8, the "Rebuild" function is found under the Application menu of the WorkPlace Tech ribbon bar.
Note: After rebuilding the application database, the object order of any or all of the control objects may change. If an attempt is made to monitor the controller containing this application, without downloading the rebuilt application to the controller, the monitor tags may display incorrect information.
Warning: Before running the "Rebuild Application" function on an application for a MNL-800 controller, confirm that index numbers have been properly assigned to ALL LON network variables and constants used in the application. Failure to confirm that all LON network variables and constants have been manually indexed could result in changes to the LON application profile (XIF file). This will result in binding issues between the controller LON network variables and other devices on the LON network.