Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84262members
353367posts

"Lost Communication With UPS"

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
steve2k7_apc
Crewman
Crewman
0 Likes
2
210

"Lost Communication With UPS"

This was originally posted on APC forums on 2/14/2008


Hi

For some unknown, unexplained reason the APCPBEAgent service on my Windows 2003 R2 server posts the above error message to the event log. Once this happens, the UPS cannot be found using the PowerChute console. A reboot of the server usually resolves the problem.

Some background:

- The server is running Windows 2003 R2
- The server is an HP ML110 G4
- I have a SmartUPS APC 1500 SC, connected directly to the server, using the APC supplied black serial <-> usb cable.
- I have the latest Java Runtime Environment (1.6.0_03-b05)
- The Prolific USB-to-Serial Comm Port (COM3) port settings are 2400, 8, None, 1, Xon/Xoff, FIFO Buffers are disabled (unticked)
- The Prolific driver is v2.0.2.1 dated 25/07/2005, provided by Prolfic, as reported by the "Driver" tab of the COM3 port.
- ser2pl.sys is v2.0.0.24, provided by Prolific, as reported by the "Driver Details" button on the "Driver" tab of the COM3 port
- serenum.sys is v5.2.3790.3959 (srv03_sp2_rtm.070216-1710), as reported by the "Driver Details" button on the "Driver" tab of the COM3 port
- I am using PowerChute Business Edition Basic v7.0.5

Right now (after a server reboot), I can run the PowerChute console and interact with the UPS w/o problem - I can view battery status info, power parameters, set shutdown config and confim that "UPS Communications" reports:

- Signalling Status - Smart Signalling
- Signalling Type - Smart
- Port Status - Comm OK
- Port - COM3

I ran into this problem before with the PowerChute version supplied on the CD and eventually gave up, uninstalling the PowerChute software and running on the native Windows 2003 UPS management (which never reported any problems with UPS communication during the month I had it configured). I saw there was a new version of PowerChute available and decided to give it another try. Low and behold I find the latest PowerChute software doing the exact same thing - for no apparent reason, just "losing" the UPS. There is no patten, there is no obvious reason.

I see someone else has reported the same problem (but no solution/confirmation of resolution was given):

http://forums.isxusergroups.com/thread.jspa?messageID=737ˡ

Any pointers appreciated

Steve


Accepted Solutions
TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
210

Re: "Lost Communication With UPS"

This was originally posted on APC forums on 2/14/2008


Steve,

The prolific driver was updated at EOY 2007. Here's the link:

http://www.prolific.com.tw/eng/downloads.asp?ID=31

That should solve the erroneous lost comm.

See Answer In Context

2 Replies 2
TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
211

Re: "Lost Communication With UPS"

This was originally posted on APC forums on 2/14/2008


Steve,

The prolific driver was updated at EOY 2007. Here's the link:

http://www.prolific.com.tw/eng/downloads.asp?ID=31

That should solve the erroneous lost comm.

steve2k7_apc
Crewman
Crewman
0 Likes
0
211

Re: "Lost Communication With UPS"

This was originally posted on APC forums on 2/14/2008


Hi Notorious

Thanks for the link, i've downloaded the file and the COM3 driver details (after a reboot) are now showing:

- Driver provider: Prolific
- Driver date: 20/11/2007
- Driver version: 2.0.2.8

Ser2pl.sys is showing:

- Provider: Prolific technology Inc.
- File Version: 2.0.2.8

I could have sworn i'd tried this before and found that the driver didn't update to the newer, downloaded version. Perhaps I was being dim when installing it. I'll keep monitoring the server and see if APCPBEAgent bottoms out again; i'll resurrect this thread if I run into further problems.

Thank you for the prompt reply - much appreciated 🙂

Steve