Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84281members
353394posts

How to disable SMTP-Auth for AP9631

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
CWempe_apc
Crewman
Crewman
0 Likes
9
579

How to disable SMTP-Auth for AP9631

This was originally posted on APC forums on 10/28/2010


Hello,

I got a problem with our new AP9631-Cards (aos513, sumx513, bootmon101).

Situation:
I configured one Card until everything worked perfect.
I wrote a script to download this config via ftp, change some values (hostname, ...) and uploaded the new config to another card.

Problem:
On first sight everything looked good.
But wehen I tried to perform a mail-test I got an error:
"Test e-mail failed; SMTP configuration error."

All mail-coresponding settings are ok!

In the next step I sniffed the network-pakages and found out that the NMC2 tries to authenticate on the smtp-server.
The first NMC does not authenticate and sends all mails correct.

Research:
I googled, but all I found were these two posts:
http://forums.apc.com/spaces/15/universal-transfer-switch/forums/general/2936/4-port-usb-hub-model-1...
http://forums.apc.com/spaces/5/smart-ups-symmetra-lx-rm/forums/general/1995/smart-ups-rt-5000-xl-unk...

Workaround:
Go to "Administration | Notification | E-mail | recipients" click on the defined recipient and hit "Apply" (without changing anything!).
Now the test-mail workes!

I guess the webinterface rewrites some part of the internal config and disables the SMTP-Auth-option.
Maybe there is a secret config-line in the internal config wich does not get exported via ftp. 🙂

My question:
How can I disable smtp-auth via ftp, telnet, ..?
Is this a known bug and will it be fixed? 😉


Thank you
Christoph


Accepted Solutions
BillP
Administrator Administrator
Administrator
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This reply was originally posted by Angela on APC forums on 12/30/2010


ok 🙂 well please post another thread if you are having issues and i'll be happy to help. happy new year!

See Answer In Context

9 Replies 9
CWempe_apc
Crewman
Crewman
0 Likes
0
579

How to disable SMTP-Auth for AP9631

This was originally posted on APC forums on 10/28/2010


Hello,

I got a problem with our new AP9631-Cards (aos513, sumx513, bootmon101).

Situation:
I configured one Card until everything worked perfect.
I wrote a script to download this config via ftp, change some values (hostname, ...) and uploaded the new config to another card.

Problem:
On first sight everything looked good.
But wehen I tried to perform a mail-test I got an error:
"Test e-mail failed; SMTP configuration error."

All mail-coresponding settings are ok!

In the next step I sniffed the network-pakages and found out that the NMC2 tries to authenticate on the smtp-server.
The first NMC does not authenticate and sends all mails correct.

Research:
I googled, but all I found were these two posts:
http://forums.apc.com/spaces/15/universal-transfer-switch/forums/general/2936/4-port-usb-hub-model-1...
http://forums.apc.com/spaces/5/smart-ups-symmetra-lx-rm/forums/general/1995/smart-ups-rt-5000-xl-unk...

Workaround:
Go to "Administration | Notification | E-mail | recipients" click on the defined recipient and hit "Apply" (without changing anything!).
Now the test-mail workes!

I guess the webinterface rewrites some part of the internal config and disables the SMTP-Auth-option.
Maybe there is a secret config-line in the internal config wich does not get exported via ftp. 🙂

My question:
How can I disable smtp-auth via ftp, telnet, ..?
Is this a known bug and will it be fixed? 😉


Thank you
Christoph

BillP
Administrator Administrator
Administrator
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This reply was originally posted by Angela on APC forums on 10/28/2010


Christoph,

this is not really a known issue. i am not sure exactly what you mean and what you saw in the network capture.

by default, in the SMTP authentication username field, you will see the value of User whether or not SMTP authentication is enabled. something needs to be in this field at all times but the password will be blank. even if authentication is required or not, it should not affect the mail server because it does not require that data. the mail server and NMC speak in commands and the mail server should ask for that info only if it is required. there really is no way to technically enable/disable email authentication.

did you upgrade to 5.1.3 from a previous firmware version or did you start with 5.1.3 from the get go?

CWempe_apc
Crewman
Crewman
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This was originally posted on APC forums on 10/28/2010


The devices were delivered with this recent software versions.
I can reproduce this problem with resetting the config.

Here are two screenshots of my sniffing with wireshark.
Both devices act the same until the smtp-server response with his parameters (blue line).

The device with the working config starts writing the mail ("MAIL FROM ...).
But the other device sends the "AUTH"-command (with parameter "LOGIN").

The question is: Why does the second device send this AUTH-command?

Remember:
Both devices are AP9631-Cards with the same Software and the same config.
I just need to re-save the recipient-settings in the WebUI to make it work!

Attachments
BillP
Administrator Administrator
Administrator
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This reply was originally posted by Angela on APC forums on 10/28/2010


alright. if you are able to send me the entire wire captures, please let me know and i will email you. if not, i will use these images for "proof."

i'd also like to get the exact step by step instructions that you did so that i can replicate it myself and not miss a step. then we can look into it further.

can you tell me what SMTP server/version that you are using?

lastly, can you please get me the event.txt and config.ini [via these instructions|http://nam-en.apc.com/app/answers/detail/a_id/9321/]

you can remove any private information from those files. i really just need the NetworkEmail section and anything else that relates to email. i will use that info when i am testing.

thanks!!

CWempe_apc
Crewman
Crewman
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This was originally posted on APC forums on 10/29/2010


I uploaded the files in the [other thread|http://forums.apc.com/spaces/5/smart-ups-symmetra-lx-rm/forums/general/4011/disable-network-watchdog...].

For the wire capture and the SMTP server/version, I will ask for permission. 😉
Do you have an email-address to send these information to?


Here is a step-by-step guide to reproduce my problem:

- reset all settings including TCP from second device (I use DHCP)
- use a script to
-- download the working config from first device (FTP)
-- change some values (HostName, DomainName, ..)
-- upload to second device (FTP)
- log into WebUI
- go to "Administration | Notification | E-mail | test" and click "Apply"
-- "Test e-mail failed; SMTP configuration error."
- go to "Administration | Notification | E-mail | recipients" and click on the defined recipient
- click "Apply" without changing any values
- go to "Administration | Notification | E-mail | test" and click "Apply" again
-- "Test E-mail sent successfully."

BillP
Administrator Administrator
Administrator
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This reply was originally posted by Angela on APC forums on 10/29/2010


thanks. as mentioned, i'll send you an email so we can work on this since i think we will need to do some testing here and escalate if necessary.

BillP
Administrator Administrator
Administrator
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This reply was originally posted by Angela on APC forums on 12/30/2010


no, thats not true. under normal circumstances, by default, the NMC will not send authentication credentials unless prompted by your mail server. we found that CWempe's particular mail server is doing something different and it is still under investigation.

thus, NMC does not have authentication enabled by default in reality and CWempe says he is not using it but via the packet capture, the mail server prompts for it.

what is your situation? please post what is happening and post your event.txt and config.ini using [these instructions|http://nam-en.apc.com/app/answers/detail/a_id/9321/]. it may also be helpful to tell us what mail server you are using and if you can get a packet capture like CWempe did, if you believe there is an issue.

poster72_apc
Cadet
0 Likes
0
579

Re: How to disable SMTP-Auth for AP9631

This was originally posted on APC forums on 12/30/2010


i may have spoke too soon.

its a strange issue, and an unpleasant setup, but we found a way to make this work. Its different than how it works on the NMC1 and thats what threw us off. The NMC1 had no issue on our exchangecluster but NMC2 needs to point to a different location.

so something is different, but we found a workaround so no biggie now

BillP
Administrator Administrator
Administrator
0 Likes
0
580

Re: How to disable SMTP-Auth for AP9631

This reply was originally posted by Angela on APC forums on 12/30/2010


ok 🙂 well please post another thread if you are having issues and i'll be happy to help. happy new year!