Warning
Electrostatic Discharge Required: Always discharge static electricity from your person by touching metal prior to handling any hardware. Failure to do so may result in damage to devices.
Issue
SmartX SpaceLogic/EasyLogic device is offline, inspection of the device's status LED reveals a solid red pattern instead of the normal solid green.
Product Line
EcoStruxure Building Operation
Environment
- SmartX SpaceLogic Controller
- SmartX EasyLogic Controller
Cause
A solid red status LED indicates the application can't be launched, typically there could be two reasons as the root cause of this situation:
- The application has become corrupted, this happens very rarely.
- Application keeps crashing on startup. To prevent an infinite startup->crash->startup loop, the firmware in the SmartX SpaceLogic/EasyLogic devices implement a feature known as the application startup retry counter, if the application has crashed multiple times, never running for longer than an internally defined time (typically 10 minutes), the boot applet will stop all attempts to launch the application.
Resolution
We can attempt to recover the device by performing the following steps:
- Cycle power to the device.
- Cold start the device by holding down the reset button for more than 5 seconds but less than 9
- If the controller starts up and shows a normal status LED (solid green), immediately start a device upgrade firmware operation, the goal is to get the uprev operation going before the application crashes again.