Issue
When changing IP settings, the change needs to be activated, before the RP-C uses the new settings.
Product Line
EcoStruxure Building Operation
Environment
Building Operation Room Controller (RP-C)
Cause
RP-C configured with static IP goes off-line or has an unexpected IP address after restart.
Resolution
If the RP-C is hosted as Dynamic but it is required to be provided with a static IP address.
RP-C IP settings can be changed to Static and saved.
However, this doesn’t save the new settings to the RP-C controller, they are only saved at the automation server level.
Therefore, if a power cycle is carried out, the RP-C is still set to Dynamic and gets an IP from the router, although it shows as static in workstation and the Ecommissioning tool.
Note: If the router is not setup as a DHCP server, the RP-C may not come back on-line, because the RP-C is looking to be provided with an IP address by the DHCP server.
Any changes to the IP settings of an RP-C made in the workstation, need to also be activated in the RP-C controller.
This is done by right mouse clicking on “IP Network Settings” selecting “IP Commands” then “Activate changes”
Now when seen in device discovery window the IP address is the static IP address configured and not the one collected from the DHCP server.
If changes are made to the IP settings using the Ecommissioning tool, prior to hosting the RP=C, the same applies, activating the changes must be done by selecting “Device restart” and selecting “Activate IP Changes” followed by “restart”.
Additional information is available by logging into the Ecostruxure Building Help page.