Issue
b3 controllers sometimes get stuck in bootloader mode (refer to Why do Continuum controllers go into bootloader mode). In b3 devices, this is indicated by the CPU LED blinking at at about half the rate of normal CPU LED blink rate.
Product Line
EcoStruxure Building Operation,Andover Continuum
Environment
All b3 devices
Cause
Need a way to recover b3 stuck in boot loader in the field.
Resolution
- Disconnect the b3 device from field bus and connect RoamIO directly to device.
- In the BACnet Service Tool, de-select the view by Networks option then click the green 'Connect' icon
- Observe the RS-485 LEDs, both on the b3 device and the RoamIO, if the connection is established the green connect icon on the service tool will have changed to red but no device will be shown since the application is missing in the device, the TD and RD LEDs will be blinking rapidly indicating the RoamIO is communicating with the boot loader in the device, if this is NOT the case then stop, recovery will not be possible, otherwise proceed to next step.
- In the 'Tools' menu, select 'Update all B3s', then send the appropriate firmware file for the device.
- After the update operation is complete, re-start the b3 device