Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
When Data Import is used in the Sigma Interface, the Data Importer fails to connect with the Sigma server.
Product Line
EcoStruxure Building Operation, Satchwell Sigma
Environment
- Building Operation Workstation
- Sigma
Cause
Sigma requires the correct release of Sigma software to be installed as well as the Sigma Transition Tool.
Installing the Sigma Transition Tool onto a Sigma server machine can mask the true version of Sigma server and client installed.
Resolution
The release of Sigma client and server that is to be transitioned into EBO should be Sigma 4.08 (build 3.46.nnn) before the Sigma Transition Tool is installed. However installing the Sigma Transition Tool will overwrite the Sigma version in the Sigma application and in the Sigma splash window when launched.
To check the true version:
1. Go to Windows Explorer and locate the directory c:\sigma\bin.
2. Identify SigOp.exe (or other files) and hover over or right click and open 'Properties' and the tab 'Details',
3. The version number should be at least 3.46.57
If the version identified is below e.g. 3.45.nnn, then Sigma needs to be upgraded to the correct release. The Sigma Transition Tool will need to be uninstalled first, the Sigma upgraded and the Transition Tool reinstalled.
When complete, rerun the Sigma Data Import in EBO.
Note: Remote Sigma clients that are connected to the Sigma server will also need to be upgraded.