Issue
- How to troubleshoot a communication issue with the Sigma interface
- Is there a log available within the ES that shows the Sigma communication between Sigma controllers and the ES
Product Line
EcoStruxure Building Operation, Sigma
Environment
- Building Operation Workstation
- Building Operation Enterprise Server
Cause
When troubleshooting Sigma issues in an ES it can be helpful to see the communication between the Sigma controller and the Sigma interface in the ES to help identify this issue. The trace log within the ES is available and is configured as described below in the resolution.
Resolution
The level of logging for Sigma in the Trace Log needs to be increased:
- Open Workstation and navigate to [ES name]/System/Modules/Trace/Loggers/nsp/nsp.pin.
- Right-click "nsp.pin.sigma" and choose Properties.
- Under Level, change from "Information" to "Trace", then click ok.
- Let it run a few minutes. If there are some user input needed to recreate the Sigma issue, then perform these steps now. e.g. If ifs a graphics issue then run the respective graphic.
- Retrieve the log by right-clicking [ES name]/System/Modules/Trace/TraceSettings and choose Trace settings->Get trace log.
- Save the log file.
- A useful tool available on the Community, the Sigma decoder can be used to assist in viewing/debugging the Sigma trace log file information saved in the previous step.
- Once debugging is complete remember to change log level back to "Information" (reverse of step 3).
Note: If the ES is restarted for any reason whether by manually stopping in the Software Administrator or other, the nsp.pin.sigma will default back to 'Information'.