Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84618members
353932posts

Lost comms with outstation on channel XX in GEO SCADA

EcoStruxure Geo SCADA Expert Forum

Find out how SCADA systems and networks, like EcoStruxure Geo SCADA Expert, help industrial organizations maintaining efficiency, processing data for smarter decision making with IoT, RTU and PLC devices.

BGedco2022
Lt. Commander
Lt. Commander
0 Likes
3
369

Lost comms with outstation on channel XX in GEO SCADA

Hello,

 

"Lost comms with outstation on channel XX"

 

our client, issue a repeated behavior around specific hour every day!!!, where most the outstations lost comm. and establish it again in seconds repeatedly as noticed in the events journal at GEO SCADA while they were really connected after checking.

 

We have traced their drivers log (modbus and dnp3) nothing found  except  shows similar messages to the events log

 

What could causes such behavior? and how to prevent it?

 

Appreciate any suggestions /hints.

 

Thanks in advance.

 

 

 

 

3 Replies 3
sbeadle
Janeway Janeway
Janeway
0 Likes
2
362

Re: Lost comms with outstation on channel XX in GEO SCADA

Hi,

 

You could enable comms logging on the channel to see what's happening at the time. Either a poll (or a number of them) are going unanswered by the device, or perhaps some noise is returned.

 

It might be that the driver is waiting for a server response and misses a reply, but if that's the case you may see the replies later in the log.

 

Steve

BGedco2022
Lt. Commander
Lt. Commander
0 Likes
1
348

Re: Lost comms with outstation on channel XX in GEO SCADA

Thanks Steve

 

We did enable Comms Logging on a sample and we will see>>>

 

But to give you more clear picture as below of the event journal of an outstation:

comm fail2.png

 

as you see the comms keeps lost and established in less than second between each event

 

Is it possible of missing or wrong configs at channel level or outstation level?

 

Thanks again 

BevanWeiss
Spock
Spock
0 Likes
0
317

Re: Lost comms with outstation on channel XX in GEO SCADA

I've seen similar behaviour in a few situations.

  • A DNP3 device firmware bug that caused it to swap the active route to the backup channel when it received a Shared Outstation Channel heartbeat.  It caused ClearSCADA to fail over channels, and then the same behaviour would occur on that channel.
  • Poorly configured firewall rule that allowed the Establishment messages (for TCP) but not Connected messages (i.e. the actual traffic).

 

Does your client have an RTU that is directly adjacent to their GeoSCADA server (i.e. that wouldn't be prone to network issues)?

Are there outstations that don't have this same behaviour?

Does the timing coincide with anything else, like network operations, large backups elsewhere, backups on the GeoSCADA Expert servers etc?


Lead Control Systems Engineer for Alliance Automation (VIC).
All opinions are my own and do not represent the opinions or policies of my employer, or of my cat..