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How to create a log file for troubleshooting video integration issues in Continuum

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How to create a log file for troubleshooting video integration issues in Continuum

Picard Product_Support
‎2018-09-06 02:12 PM

Issue

There is a need to get logging details for troubleshooting video integration issues in Continuum.

Product Line

Andover Continuum

Environment

  • Continuum
  • Windows XP
  • Windows Vista
  • Windows Server 2003
  • Windows Server 2008

Cause

There is an issue with the video integration and there are specific instructions to enable video troubleshooting in Continuum.

Resolution

Continuum versions 1.9x and above contain a helpful tool for troubleshooting video integration issues

To enable video logging, follow these instructions:

  1. Shut down Continuum on the Cyberstation you will use to create the log file
  2. Using Windows notepad, edit the file log4net.config located in C:\Program Files\Continuum
    At the bottom of the file locate the following text: 
  3. <root>

    <level value ="WARN"  />

Change WARN to DEBUG (Ex. level value ="WARN" ---> level value ="DEBUG" )

From the pull down menu, File> Save and close the file

        4.Start Continuum and test one isolated procedure at a time (Ex. video isn't displaying on alarm)

        5. Email the video.log file from the C:\Program Files\Continuum folder to the support engineer for analysis

Note: Make a copy of the video.log file ( to save the file ) and then delete the original. A new video.log file is created each time Continuum is started with the level value="DEBUG" set

Video log changes for 1.92/1.93/1.94

The instructions to enable the video.log are the same as for 1.91, however the results have been broken into a number of different files

VideoAdmin.log - used for configuration 

AccVideoRecordingServc.log - used for camera learn

VideoLayout.log - used for video layout 

AlarmView.log - used for video alarms

Easiest way to see what file was written to is to sort the Windows folder by the Type column and check the txt file(log) dates

Note: In Microsoft Vista or Windows Server 2008, if account control is not disabled the video log files may get written to "C:\users\username\AppData\Local\VirtualStore\Program Files\Continuum"

Caution: Once the debugging process has been completed, go back into the log4net.config file and edit the file.

  1. Change the DEBUG to WARN (Ex. level value ="DEBUG" ---> level value ="WARN")
  2. From the pull down menu, File> Save and close the file

This will stop the files from growing too large.

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