Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84338members
353514posts

apcupsd can't connect to Smart-UPS 2200/Network Management Card 2

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
bvgadmin_apc
Cadet
0 Likes
1
861

apcupsd can't connect to Smart-UPS 2200/Network Management Card 2

This was originally posted on APC forums on 6/13/2017


Hi,

I've got a problem to reach an UPS with apcupsd over ethernet.

Here my Setup:

Smart-UPS 2200 (Firmware Revision: UPS 09.3 (ID18)) with an Network Management Card 2 - AP9630 (Version: v6.2.0)
DNS bvg-usv001
IP 192.168.65.24
debian host with apcupsd
DNS bund-shutdown
IP 192.168.66.26

The apcups_conf:

UPSNAME bvg-usv001
UPSCABLE ether
UPSTYPE pcnet
DEVICE 192.168.65.24:admin:test123

LOCKFILE /var/lock
SCRIPTDIR /etc/apcupsd
PWRFAILDIR /etc/apcupsd
NOLOGINDIR /etc
ONBATTERYDELAY 6
BATTERYLEVEL 5
MINUTES 3
TIMEOUT 0

ANNOY 300
ANNOYDELAY 60
NOLOGON disable
KILLDELAY 0

NETSERVER on
NISIP 127.0.0.1
NISPORT 3551

EVENTSFILE /var/log/apcupsd.events
EVENTSFILEMAX 10

UPSCLASS standalone
UPSMODE disable

STATTIME 0
STATFILE /var/log/apcupsd.status
LOGSTATS off
DATATIME 0

The account and password work with the Website. But I got still a comlost:

apcaccess 
APC : 001,018,0458
DATE : 2017-06-13 10:29:39 +0200
HOSTNAME : bund-shutdown
VERSION : 3.14.12 (29 March 2014) debian
UPSNAME : bvg-usv001
CABLE : Ethernet Link
DRIVER : PCNET UPS Driver
UPSMODE : Stand Alone
STARTTIME: 2017-06-13 10:29:36 +0200
STATUS : COMMLOST
MBATTCHG : 5 Percent
MINTIMEL : 3 Minutes
MAXTIME : 0 Seconds
NUMXFERS : 0
TONBATT : 0 Seconds
CUMONBATT: 0 Seconds
XOFFBATT : N/A
STATFLAG : 0x05000100
END APC : 2017-06-13 14:19:25 +0200

When I test the port on bvg-usv001:

nmap -p 3052 bvg-usv001
Starting Nmap 6.47 ( http://nmap.org ) at 2017-06-13 14:23 CEST
Nmap scan report for bvg-usv001 (192.168.65.24)
Host is up (0.0063s latency).
rDNS record for 192.168.65.24: bvg-usv001.bvg.local
PORT STATE SERVICE
3052/tcp closed powerchute
MAC Address: 00:C0:B7:ED:0B:DA (American Power Conversion)
Nmap done: 1 IP address (1 host up) scanned in 0.46 seconds

I guess I've to open the port?

On the USV I tried to set the debian Server as Powerchute Client, but that didn't open the port. I doesn't do anything on the firewall 😉

Bye

Gregor


Accepted Solutions
Brad_C_apc
Commander
Commander
0 Likes
0
861

Re: apcupsd can't connect to Smart-UPS 2200/Network Management Card 2

This was originally posted on APC forums on 6/14/2017


The PCNET driver relies on a passphrase rather than a password. On my AP9606 it defaults to "admin user phrase". So the driver needs to look like this :

UPSTYPE pcnet
DEVICE 192.168.2.231:apc:admin user phrase


You might want to re-check your authentication just to ensure it is set up right.

If you fire up tcpdump you should see the PCNET packets back and forwards, from memory they are plaintext anyway.

See Answer In Context

1 Reply 1
Brad_C_apc
Commander
Commander
0 Likes
0
862

Re: apcupsd can't connect to Smart-UPS 2200/Network Management Card 2

This was originally posted on APC forums on 6/14/2017


The PCNET driver relies on a passphrase rather than a password. On my AP9606 it defaults to "admin user phrase". So the driver needs to look like this :

UPSTYPE pcnet
DEVICE 192.168.2.231:apc:admin user phrase


You might want to re-check your authentication just to ensure it is set up right.

If you fire up tcpdump you should see the PCNET packets back and forwards, from memory they are plaintext anyway.