Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84783members
354229posts

Preventing runtime calibration on reboot

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
aedge44_apc
Crewman
Crewman
0 Likes
8
1275

Preventing runtime calibration on reboot

This was originally posted on APC forums on 10/29/2008


I have an older APC SmartUPS so I have to run PowerChute 5.2.3 to support it. The UPS goes into a runtime calibration when I restart the computer (Windows XP). The release notes say that the computer sends characters out the com port when it restarts. These are misinterpreted by the SmartUPS as a command to do a runtime calibration.

Is there some way to avoid this problem besides unplugging the serial cable?


Accepted Solutions
voidstar_apc
Janeway
Janeway
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 11/1/2008


I'm glad to hear that it worked! It's great when you can reuse old equipment rather than scrapping it.

See Answer In Context

8 Replies 8
TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 10/30/2008


Why're you still running PC+ 5.2.3?

What's stopping you from moving to PCBE either 7.0.5 or 8.0?

That may make the problem go away.

aedge44_apc
Crewman
Crewman
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 10/30/2008


I installed the newer software first and it says that my UPS is not supported.

EZ_Button_apc
Commander
Commander
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 10/30/2008


Just curious, what UPS model # do you have? Also, what cable is attached? There should be a part number stamped into one of the ends of the cable.

aedge44_apc
Crewman
Crewman
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 10/31/2008


It's a Smart-UPS 400. The manufacturing date according to Powerchute is June 6 1994.

Message was edited by: admin

Erasmus_apc
Sisko
Sisko
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 10/31/2008


The UPS is very old...well past it's life cycle While this is not guaranteed to cause you any issues with unit performance, I would not be surprised at all if there was a communication port issue of some kind. I would recommend getting a new unit honestly. But replacement aside, I would like to see you try restarting the computer with NO serial cable attached to the UPS and see if the problem continues.

Honestly I see this as a either an a) serial comm. issue on the UPS or a bad serial cable.

By the way the APC 940-0024(x) cable pin outs are proprietary and we do not provide them, and so I will need to make a request to have your previous post deleted. In addition, the ground reference you mentioned is incorrect in reference to our 940-0024C and D signaling cables, and the 4-5 connection is not even something I see anywhere here on our pin out spec. I will admit part of your cabling is correct so I can see how you did get some communication. I would recommend buying a 940-0024 cable from APC's website.

voidstar_apc
Janeway
Janeway
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 10/31/2008


Like you, I had a problem with the computer treating my serial port as a mouse. Rather annoying and it prevented me from using the serial port at all after a reboot. I had success with [the procedure here|http://windowsitpro.com/article/articleid/13817/how-do-i-disable-mouse-detection-on-a-com-port-for-u...].

Additionally, parties interested in the UPS's RS232 connector should check out [APC's Documentation|http://nam-en.apc.com/cgi-bin/nam_en.cfg/php/enduser/std_adp.php?p_faqid=1481].

aedge44_apc
Crewman
Crewman
0 Likes
0
1275

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 11/1/2008


Thank you, the /noserialmice=com1 fixed the problem! I was hoping that there was some way to turn off whatever it was that Windows was sending out of the com port during a boot. I tried restarts and cold boots and no more battery runtime calibrations.

This old UPS came back to us as part of a trade in when our customer upgraded their machinery + the old workstation. It was going to be scrapped & recycled so I took it home. It still works fine even though it is 14 years old and well-used. The batteries are new.

BTW - my cable is fine. The 4-5 connection is valid as pin 4 is common (logic ground) according to the computer interface diagram in the APC Smart-UPS 400 user guide page 26. Pin 9 is chassis ground on the UPS and it is internally hardwired to pin 4 anyway. I see that the link on your message shows that pin 4 is the correct pin to connect to the COM port common (pin 5).

voidstar_apc
Janeway
Janeway
0 Likes
0
1276

Re: Preventing runtime calibration on reboot

This was originally posted on APC forums on 11/1/2008


I'm glad to hear that it worked! It's great when you can reuse old equipment rather than scrapping it.