Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84245members
353344posts

PowerChute cannot communicate with the Management Card

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
wkk001_apc
Ensign
Ensign
0 Likes
27
1336

PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/12/2007


Hello
I'm newbie of APC. Now i installed Smart UPS 3000 and AP9617 Network Management Card. I also PowerChute Network Shutdown version 2.2.1 on my servers (openSuSE 10.2 (linux)). When i install Powerchute, there is no problem. When i open web interface for powerchute (http://localhost:3052), there is a error "PowerChute cannot communicate with the Management Card". But in the Network Management Card's Web interface, there is my servers addresses. I cannot call powerchute web interface from other computer via server's address (/http://:3052). I don't know what things wrong. I followed instructions of installation guide. But I can't. This is my first time APC Management Card Installation.
Pls Help me.

Thanks in advance to anyone that responds to this post.


Accepted Solutions
EZ_Button_apc
Commander
Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/14/2007


Does this server happen to have multiple NIC's? If so, try disabling the alternative NIC's and do a reinstall. Wait a few minutes for comm to establish and then reenable your other NIC's.

I'm not sure I completely understand your second question. Do you want to disable access to the web interface?

See Answer In Context

EZ_Button_apc
Commander
Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/18/2007


No problem, were you able to get the uninstall figured out?

See Answer In Context

27 Replies 27
EZ_Button_apc
Commander
Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/14/2007


You will need to access the install directory and run the uninstall script.

I believe it's "usr/local/bin/powerchute".

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/12/2007


Hello
I'm newbie of APC. Now i installed Smart UPS 3000 and AP9617 Network Management Card. I also PowerChute Network Shutdown version 2.2.1 on my servers (openSuSE 10.2 (linux)). When i install Powerchute, there is no problem. When i open web interface for powerchute (http://localhost:3052), there is a error "PowerChute cannot communicate with the Management Card". But in the Network Management Card's Web interface, there is my servers addresses. I cannot call powerchute web interface from other computer via server's address (/http://:3052). I don't know what things wrong. I followed instructions of installation guide. But I can't. This is my first time APC Management Card Installation.
Pls Help me.

Thanks in advance to anyone that responds to this post.

Sgt._Slaughter_apc
Lt. Commander
Lt. Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/12/2007


Hello,

Here is some basic steps to check for lost communication between PCNS and your Network card. First, what is the firmware of your network card? If the menus are across the top, then go to Admin - General - About. If the menus are down the left side, go to Help - About System. The newest firmware is 3.5.5

If the Management Card says Lost Comm in its event log then the problem is with the Management Card and the UPS. All the PCNS clients would then have a message indicating they are not communicating with the Management Card.

If the Management Card has the message ?Communication Established?, but the PCNS client or clients show Comm lost, it could be:
 PCNS does not have the correct IP address for the Management Card
 PCNS does not have the same Admin user name or Admin Authenication Phrase of the Management Card.
 Firewall or DMZ, Filtering software or antivirus software preventing packets from being sent on port 3052.

If one machine can not establish communication with the Management Card go to the server and at the command prompt type netstat ?a and this will give you a listing of the ports in use on that machine. See if UDP port 3052 is in the list. If it is not in the list then PCNS on that machine did not start or is not running properly.

Let us know. Thanks.

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/13/2007


Thank u so much for ur reply.
After I followed ur instruction to add 3052 into firewall, I can run PowerChute web interface from remote computer. And also I can found my server IP address in connected server tag. But in Event Log, there is error "PowerChute cannot communicate with Management Card" until now. And also I can't shutdown my servers from Management Card. UPS only shutdown. Management Card cannot send shutdown command to my servers. May I need to write a script for shutdown from UPS? Pls Help me!
Thanks You So Much!

Message was edited by: wkk001

Sgt._Slaughter_apc
Lt. Commander
Lt. Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/13/2007


Hello,

Have you made sure the PCNS client has the same username and password as the NMC? Does PCNS on another box talk to the Network Card in the UPS just fine? We cannot exactly write the script for you, but we can make sure it runs from PowerChute Network Shutdown.

Is there any internal firewalls or antivirus software you may be using thats blocking 3052 from the UPS to your PCNS client? Made sure the IP of the client is listed in the Network Card interface? What is the firmware on your Network Card?

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/14/2007


Hello
Yes, I have the same user and password for both PCNS and NMC. I opened port no 3052 in the firewall of all servers. In the Network Card Interface, there is server IP and all of clients IP. My Network Card firmware is 661.6.
pls help me!
I reinstall Power Chute in the server. but the error is occur until now. and also i want to ask how to remove PowerChute client IP in the server when i installed with silent installation. pls give me some instrucitons!

Thanks a lots,
Best Regards,
wkk

EZ_Button_apc
Commander
Commander
0 Likes
0
1337

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/14/2007


Does this server happen to have multiple NIC's? If so, try disabling the alternative NIC's and do a reinstall. Wait a few minutes for comm to establish and then reenable your other NIC's.

I'm not sure I completely understand your second question. Do you want to disable access to the web interface?

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/14/2007


Yes, i have some servers, they have multiple NICs. Now I'm other place. so i will reinstall by disabling NIC's later.
My second question is : i installed complete installation in one server. And then i install silent installation in other servers that i want to shutdown from UPS. In the testing case, i install silent installation in some PC. That is just only testing. So i want to remove PCNS from that PC, and also i want to remove that IP from PCNS web interface. So how can i remove and uninstall?
Thanks u so much for ur at once reply!
With Thanks a lots,
wkk

Message was edited by: wkk001

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/15/2007


In the PCNS server, there is that path (usr/local/bin/powerchute). But in other servers that have PCNS silent installation, there is not that path. So there is no uninstall script. So I cannot uninstall.

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/17/2007


Thanks u very much for all.
Now I can control my servers' shutdown over network management card. I need to stop my friewall from all servers. And also before installation, i need to disable other NICs.
Thanks all of u!
Best Regards,
wkk

EZ_Button_apc
Commander
Commander
0 Likes
0
1337

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/18/2007


No problem, were you able to get the uninstall figured out?

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/18/2007


Hello,
When disable firewall and run PCNS, PCNS can communicate with Network Management Card. After enable firewall, it cannot communicate again. I opened ports 3052, 161, 162 and 80 in my firewall. But It still cannot communicate. Pls Help me! I can well communicate and control when firewall is disable. But Enable, I cannot. So Pls again!

EZ_Button_apc
Commander
Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/18/2007


Make sure 3052 is open for incoming and outgoing signals for UDP and TCP. You may want to contact the firewall manufacturer to make sure the ports are truely open.

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/19/2007


Hello
I run PCNS on Suse 10.2, so i open both UDP and TCP ports in YaST Firewall. May i need to open that ports in other places?

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/19/2007


pls help me,
i need to configure that during this week. and also i can't disable my firewall all time. how can i do for it. I need to open other ports in firewall for PCNS.
Pls help me!

EZ_Button_apc
Commander
Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/19/2007


Since enabling your firewall seems to stop the communication, I would assume that's the only place you would need to open ports. I'm not sure how your firewall is effecting it, since you say the ports are opened. You may want to try stopping and starting hte PCNS service. Just go to the install directory and type ./PowerChute stop .... then ./PowerChute start .

Have you tried reinstalling with your firewall enabled too? I just want to see if any error is generated during this process.

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/20/2007


Thanks u so much!
Yes, I tried reinstallation with both firewall enable and disable. when during installation, there is no error. I stop and start PowerChute again and again. but there is noting changes.
I also don't know. How to solve that problem. How should i do. I can't disable my firewall all time, and also i need to control servers shutdown via NMC. Pls Help me!!

EZ_Button_apc
Commander
Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/20/2007


Unfortunately I'm not familiar with that firewall, but it seems pretty straight forward that it is the culprit in somehow denying the communication. It is just ports 3052 and 80 that you need to worry about.

Have you tried contacting your firewall manufacturer yet?

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/24/2007


Hello
now i upgrade my firmware to 3.5.5, and open 3052 in my firewall, but still cann't communicate PCNS and NMC. what should i do. pls help me. my OS is openSuSE 10.2 and i used YaST2 Firewall. During the PCNS installation, there is no problem. But in the web interface of PCNS, the error still occur. How can i repair my firewall to communicate PCNS and NMC. ThanX a lots.
Best Regards,
wkk

Sgt._Slaughter_apc
Lt. Commander
Lt. Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/24/2007


PCNS talks to the Network Card via ports 80, 161, 162, and 3052. Make sure these ports are open.

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/25/2007


I surely added that ports in my firewall. when i run with netstat, i found that port. but until i cannot communicate PCNS and NMC. i don't know why? May i need to add some configurations to NMC web interface and PCNS web interface? Pls help me !
with Thanks a lot,
wkk

Sgt._Slaughter_apc
Lt. Commander
Lt. Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/25/2007


Have you made sure that the username, password, and authentication phrase hasn't been altered in the NMC? These fields need to be 100% exact in order for PCNS and the NMC to communicate.

This may be an issue where you might want to speak live to an APC rep. Open up a live line of communication and get your issue logged into our system. If everything checks out, we may need to escalate any issues for a resolution.

800-890-4272

Thanks.

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 9/27/2007


Yes , I made sure that username, password, and authentication phrase. I don't understand about resolution. what means? i don't know. so pls help me. i made sure ip address of NMC, username, password, authentication phrase and opening ports (3052, 80, 161, 162). But still PCNS can't communicate with NMC whenever i enable my firewall. Pls
Thanks,
wkk

pseudo_apc
Cadet
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 5/22/2008


Is there a solution for the problem meantime? We've got exactly the same problem, with activated firewall on SuSE Linux Enterprise Server 10 SP1.

thx pseudo

EZ_Button_apc
Commander
Commander
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 5/27/2008


If your firewall being enabled stops communication, then make sure port 80, port 3052, and port 6547 are fully open.

pseudo_apc
Cadet
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 5/28/2008


Thanks for reply, but with this settings it doesn't work! However, yesterday i've found the solution for the communication problem:

Configuration of /etc/sysconfig/SuSEfirewall2:

[...
FW_SERVICES_EXT_TCP="80 3052 6547"
FW_SERVICES_EXT_UDP="3052"
...]

and now the real solution for the problem

[...
FW_ALLOW_FW_BROADCAST_EXT="3052"
...]

Greets pseudo

wkk001_apc
Ensign
Ensign
0 Likes
0
1336

Re: PowerChute cannot communicate with the Management Card

This was originally posted on APC forums on 11/14/2008


Thanks You So Much ALL!!
Now it work!
If you use openSUSE 10.3, it already solved.
But if you use old version, you can use YaST2 Firewall. Add that port into broadcast.