Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel

My Experience with PowerChute Business Edition 9.2 (Windows 7/Server 2012) - With Advice.

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.


My Experience with PowerChute Business Edition 9.2 (Windows 7/Server 2012) - With Advice.

This was originally posted on APC forums on 5/22/2017

I've just had 3 days of extreme pain trying to get PowerChute Business Edition 9.2 working properly and I want to share my experiences and advice with the wider community, so that anyone who's having difficulties can at least find some answers and have things to try.

I was using a Windows 7 (x64) Enterprise machine.  Nothing special, with the exception of a 10GBit Intel X520-SR2 Network card.

Now, I've used a APC BackupPro 2200VA for a long time and PowerChute Personal Edition and it just worked.  Connect the UPS to the PC using the cable supplied (RJ45 to USB), install the software and voilá, you're done.  Nice unobtrusive icon in your tray and everything.  Why should I expect that when I changed UPS to a APC Smart-UPS SMX2200HV and started using PowerChute Business Edition should have 3 days of endless arsing-around trying to figure out why it won't work?

I really hope APC takes this on board because they seriously need to.

APC make in my opinion the best UPS hardware and I'm quite brand loyal, but their PowerChute Business Edition is nothing short of a dang joke.  Now I code games for a living and if I wrote software as shonky and as unintuitive as PowerChute Business Edition, I'd end up having a chat with my line-manager, followed by another with HR before being escorted out of the building.  It's just BAD, so very bad and this is such a shame for a maker of such great hardware.

Let's gloss over the fact that the interface looks like it's been designed in Microsoft Paint; the main issue is, when it doesn't work, you've little or no-chance of fixing it without tons of experimentation because the logs (what there of them) are next to useless.  You've simply no idea where the problem might be.  The worst thing though is by far, the documentation.  It might as well just say, "Here matey, install this, cross your fingers, good luck, laterz".

So, let's go through the mistakes I made and hope I can help other people:-

  • The cable:  I had a APCUPS BackupPro which connected to the computer with a USB and a RJ45 for the UPS.  I thought, no worries, I'll use this same cable for my new APC Smart-UPS SMX2200HV as everything is fairly standardised nowadays...  But oh no, that's just not how it is with APC.  (We like to change leads as often as Apple like to change connectors).  Now my Smart-UPS was supplied with a USB -> USB lead and a RJ45 -> RS-232 lead, so after some playing around trying to get the computer to see the UPS, I decided to go with the USB -> USB  Immediately, because USB is plug and play (or at least supposed to be) the computer popped a notification saying it was installing APC Batteries and I got an entry for Batteries in my device manager.  Yay, I thought, my tales of woe are over... or so I thought.  Still, I couldn't get the computer to see the UPS.  I was puzzled as to why APC decided to include a RJ45 -> RS-232 cable, I mean, what computer has an RS-232 port anymore?  There's backward compatibility and then there's backwards compatibility, but still.

Many hours passed by whilst I researched the issue trying everything from changing passwords on the Server and Agent to Brain Dead the UPS.  Literally everything I could think of and nothing seemed to allow my computer to see my UPS.

PowerChute Business Edition is made up of 3 components, an Agent (which is installed as a Windows Service) and has no interface, a Server which can either be installed locally to the agent (Also a Windows Service) and a console.  In my case, I thought about running the Server on another remote machine, but since I couldn't even get things to work locally, didn't even think about going down this road.  The machine I was installing on had 2 10GBit NICs both on different subnets as one is used for an iSCSI mount.  So I though this might be the problem... maybe the software is trying to communicate on the wrong NIC.  In the console, I could see my agent but each and every time I'd get a "Failed to apply configuration profile" when trying to add it.

The insanity here is that almost ANYTHING can give you this message.  If the computer can't see the UPS, if the password for the Agent is different than the one on the server, if the UPS isn't supported, if the wind is blowing from the east instead of the west, or if you think batman is lame.  Literally anything.  No explanation, nothing, just this failure message with absolutely no indication as to what might be wrong.

Also the most annoying thing in the world is that for nearly everything, you're required to uninstall and reinstall the agent.  I'd done this about 50,000 times, coupled with rebooting the machine, changing passwords, selecting USB, DB9, everything I could think of and now it was 3 days later.  As I said, even Brain Dead the UPS just in case that might be the issue.

Then by chance I came across an article talking about drivers.  Now I'd already thought about updating the drivers for the USB connection and even tried doing that, but this was talking about Human Interface Devices.  HID devices I hear you say?!  What has an APC UPS got to do with HID devices?  Well, quite a lot as it turns out.  It showed an example of how to click the APC UPS Batteries in the device manager, select Browse My Computer for driver software and then Let me pick from a list of device drivers on my computer and finally select APC UPS.  Now it's been a fair few years since I've needed to install a driver by hand like this, but after installation, I got an APC UPS listed in my Human Interface Devices.  Yay, so I gave the console one more go and to my utter amazement, it actually worked and the computer could now see the UPS.

So what are the lessons that have been learned here...  What can I do if I'm having the same problems?

  • 1)  Use the supplied cable for attaching the UPS to the computer.  (Don't use common sense and logic because APCare reading from a completely different book of logic)
  • 2)  The password you set for your agent MUST be the same as the one you set on your server.  Otherwise you'll get the nice generic "Failed to apply configuration profile".
  • 3)  Make sure in the device manager you've got APCUPS listed under both batteries and Human Interface devices or the connection will not work between your UPS and computer.
  • 4)  Check to see if your UPS is supported by PowerChuteBusiness Edition.  You can't use Business Edition if it was supplied with Personal for example.
  • 5)  It might seem crazy, but very minor changes to configuration might need you to stop and start your agent service, or even re-install it.  It's a real pain in the ass, but what can I say?  I didn't write the software.  If you extract the SFXarchive that is supplied with PowerChute Business Edition, you can install each component separately as they're just 3 separate InstallShield installations in their own folders.
  • 6)  Check your network interfaces and ensure that the server subnetis listed first when trying to add an agent.  This shouldn't be a problem if you're installing the server and client locally to each other, but it will if the server is sitting on a remote machine.  I did read somewhere about installing some kind of loopback device if your sever and agent are local to one another specifying as the subnet, but you'll need to research this further.

In conclusion, what I had and from what I've read others have had, is a dang terrible experience with PowerChute Business Edition.  Such a shame when Personal just works right out of the box.  The interface looks like it was put together with a crane and the entire thing is written as some awful Java application.  I mean, come on, I know you want cross-platform, but given your interface, I could knock that together in MFC in like half-a-day and to port it to other platforms is hardly a massive undertaking for such a simple interface.  It's a bit of a joke for such a great piece of hardware.

Also, WHY OH WHY are you not installing the necessary drivers for the USB connection to work out of the box?  Why should it take hours of research to make your crap work?  I understand your concept of server and agent etc, that's fairly standard, but surely you test your software, right?  How come you've got such a great QA procedure for testing your hardware and obviously don't have one for your software?  I just hope you're listening here because I'm tech savvy and even I found it beyond frustrating, so what chance has someone who is less so?

Please please PLEASE just get better at this software thing, okay?  It's SO important when your excellent hardware has to interface with stuff.


Rant over.


Accepted Solutions
Administrator Administrator

Re: My Experience with PowerChute Business Edition 9.2 (Windows 7/Server 2012) - With Advice.

This reply was originally posted by Bill on APC forums on 5/23/2017


Sorry for the inconvenience. Your rant has been noted. 

See Answer In Context

1 Reply 1
Administrator Administrator

Re: My Experience with PowerChute Business Edition 9.2 (Windows 7/Server 2012) - With Advice.

This reply was originally posted by Bill on APC forums on 5/23/2017


Sorry for the inconvenience. Your rant has been noted.