Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84525members
353768posts

Energy Usage monitoring not available, APC Data Service not running

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
JasonD_apc
Ensign
Ensign
0 Likes
6
926

Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/7/2011


The icon for PowerShute 3 show an exclamation mark, claiming "energy usage is not being monitored - APC Data Service not running". The program itself claims at the bottom, "Energy Usage monitoring not available."

I went into Services and started it. It was already set to "automatic" for starting. Is this proper? Should I change it to something else?

P.S. Constructive feedback: It would be better if the program itself stated the reason why it wasn't working. Instead it shows a power usage bar as though it is working. But at the bottom it says that it isn't. This is conflicting info. I didn't realize how to fix this until I moused over the icon to see that it said the service isn't running (which is definitely better than saying nothing at all!), but I expected by clicking the icon to get to the program to be told what was going on. (Also, If it couldn't start the service, shouldn't it tell me?)

Thanks,
Jason Doucette


Accepted Solutions
drstephencw_apc
Crewman
Crewman
0 Likes
0
926

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 8/10/2014


I have this same problem on one computer.  As an experiment, I have set the start mode for the APC Data Service to "Automatic with Delay"; sometimes services fail to start because they need some other service that hasn't started yet.  I don't have any results yet but this is something you might want to try.  (The delay is about 2 minutes since the last automatic service was started.)

See Answer In Context

JasonD_apc
Ensign
Ensign
0 Likes
0
926

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/7/2011


Thanks for the reply. I just rebooted my computer again -- and a 3rd time -- and each time, the APC Data Service is not running, and thus the icon is showing the exclamation mark.

I went into Services, and again the "Startup type:" is set to Automatic, the "Service status:" is Stopped. I can click "Start" to start it... but why isn't it starting automatically when it's set to automatic? This is weird. I've never had a service do this before. Is there something else I need to do to make sure it starts automatically?

Thanks for your help!
Jason Doucette

Message was edited by: JasonD

See Answer In Context

JasonD_apc
Ensign
Ensign
0 Likes
0
926

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/8/2011


I rebooted some more times, with some of them resulting in both services running, and some resulting in both not running.

This is unfortunate,since I cannot use it to compute the energy used, since it's not always running when it should be. Not that I need this, but since it's keep stats, it would be cool to know, although it'll simply be inaccurate if the services are not actually running. Also the data service is nice to check on the system to see that it's working properly, and the other service is NEEDED to proper windows shut down -- so the device won't even work if I'm not here to shut it down manually!!

Please help...

Jason Doucette

See Answer In Context

s2me_apc
Crewman
Crewman
0 Likes
0
926

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/21/2011


Hi. Same problem with my Back pro 900 and PCPE 3.0 on Windows 7 x64. both apc services are set to start automatically. when boot process completes, apc data service is always not running, second service is always running. How to set data service to run automatically?

Tech data:
Model: Back-UPS BR 900GI
Serial number: 3B1035X08632
Firmware revision: 879.L1d.I
Software version: PowerChute Personal Edition 3.0
Date of last manual self-test: 14.09.2011
Result of last manual self-test: Passed
RAM: 4,00 GB
Free disk space: 103,41 GB

Please reply.

See Answer In Context

6 Replies 6
drstephencw_apc
Crewman
Crewman
0 Likes
0
927

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 8/10/2014


I have this same problem on one computer.  As an experiment, I have set the start mode for the APC Data Service to "Automatic with Delay"; sometimes services fail to start because they need some other service that hasn't started yet.  I don't have any results yet but this is something you might want to try.  (The delay is about 2 minutes since the last automatic service was started.)

BillP
Administrator Administrator
Administrator
0 Likes
0
926

Re: Energy Usage monitoring not available, APC Data Service not running

This reply was originally posted by Chris on APC forums on 9/7/2011


It should be listed as automatic but did it show started? If you double click on the service, does it show started? If no, click on start. Also, make sure the APC UPS service is automatic and started.

JasonD_apc
Ensign
Ensign
0 Likes
0
927

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/7/2011


Thanks for the reply. I just rebooted my computer again -- and a 3rd time -- and each time, the APC Data Service is not running, and thus the icon is showing the exclamation mark.

I went into Services, and again the "Startup type:" is set to Automatic, the "Service status:" is Stopped. I can click "Start" to start it... but why isn't it starting automatically when it's set to automatic? This is weird. I've never had a service do this before. Is there something else I need to do to make sure it starts automatically?

Thanks for your help!
Jason Doucette

Message was edited by: JasonD

JasonD_apc
Ensign
Ensign
0 Likes
0
926

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/7/2011


I should note that the other service, APC UPS Service, is also set to Automatic, and it started up just fine on its own on my 1st and 2nd reboots, but it did NOT start on my 3rd.

It's almost like the PC is bogged down and the service doesn't get a chance to start, so it just gives up and never tries again.

Also, starting one of the services when they are both not running will start them both. And this always works. So if it just waited and tried again later, it'd be fine.

Jason Doucette

Message was edited by: JasonD

JasonD_apc
Ensign
Ensign
0 Likes
0
927

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/8/2011


I rebooted some more times, with some of them resulting in both services running, and some resulting in both not running.

This is unfortunate,since I cannot use it to compute the energy used, since it's not always running when it should be. Not that I need this, but since it's keep stats, it would be cool to know, although it'll simply be inaccurate if the services are not actually running. Also the data service is nice to check on the system to see that it's working properly, and the other service is NEEDED to proper windows shut down -- so the device won't even work if I'm not here to shut it down manually!!

Please help...

Jason Doucette

s2me_apc
Crewman
Crewman
0 Likes
0
927

Re: Energy Usage monitoring not available, APC Data Service not running

This was originally posted on APC forums on 9/21/2011


Hi. Same problem with my Back pro 900 and PCPE 3.0 on Windows 7 x64. both apc services are set to start automatically. when boot process completes, apc data service is always not running, second service is always running. How to set data service to run automatically?

Tech data:
Model: Back-UPS BR 900GI
Serial number: 3B1035X08632
Firmware revision: 879.L1d.I
Software version: PowerChute Personal Edition 3.0
Date of last manual self-test: 14.09.2011
Result of last manual self-test: Passed
RAM: 4,00 GB
Free disk space: 103,41 GB

Please reply.