Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84579members
353848posts

Email notifications not working since upgrade

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
BillP
Administrator Administrator
Administrator
0 Likes
16
407

Email notifications not working since upgrade

This question was originally posted by george_au on APC forums on 1/17/2011


Hello

I recently purchased a new ups and managment card for one of my remote sites and thought it best to get the newest firmware and was nearly about to upgrade all my other ones as well when I found email notifications never arrive from this new unit. I never recieve an error, just nothing ever comes, If I do a test run it says test sent successfully. I have the same config almost at 11 sites of a 3000xl ups and usually the older management card but this came with the AP9630 which is running 5.1.3, my others are AP9617 and 3.5.8. Is there any log I can check on the card to see what is happening ? Before anyone asks me to check the email servers I dont have any access to them and the admins dont support me having notifications or want to know about it working or not working(Although it works at all other 11 sites and at this site I have backupexec notifications running normally with the same config, I am allowed to use non existent addresses to send from and I dont use authentication. Any help is greatly appreciated


Accepted Solutions
BillP
Administrator Administrator
Administrator
0 Likes
0
407

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 1/21/2011


hmm ok. i understand. can you provide me the event.txt and config.ini of your NMC giving you the issue? You can delete any sensitive info out of them if you want. follow [these instructions|http://nam-en.apc.com/app/answers/detail/a_id/9321] to gather them if you want.

See Answer In Context

16 Replies 16
jttallman_apc
Crewman
Crewman
0 Likes
0
405

Re: Email notifications not working since upgrade

This was originally posted on APC forums on 2/3/2011


Yes, I would like to try the 5.0.3 firmware. Currently we don't need IPv6 and the other add-ons at this moment.

jttallman_apc
Crewman
Crewman
0 Likes
0
405

Re: Email notifications not working since upgrade

This was originally posted on APC forums on 2/3/2011


I might have the same issue also. My setup. Smart-ups SMT750 with NMC AP9631. The default firmware is 5.0.x and I do not get the UPS tab on the web console. The config.ini has the entry "UPS not recognized" but email notification works. Then I upgrade to 5.1.1 or 5.1.3 and I get the UPS tab but then email fails. So either firmware make the unit worthless right now. Thanks

BillP
Administrator Administrator
Administrator
0 Likes
0
405

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 2/3/2011


ok but note if you downgrade you will lose your IP settings.

the email support rep that i was working with has the link to the firmware. he should be able to provide it to you via email but if you do not want to do that, i will PM you the link to the firmware via the forum.

BillP
Administrator Administrator
Administrator
0 Likes
0
405

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 2/3/2011


john,

someone just escalated your case to me via email. i replied back with several points that i will post here as well:


Ultimately, the UPS the NMC is installed into has nothing to do with email. I looked in the chat transcript you had and found that neither the rep you spoke to or yourself didnt know the fact that SMT/SMX UPSs were only supported in sumx 5.0.3 application or higher and you started out with 5.0.0 sumx application - that is why you did not get a UPS tab. I told the rep this as well as to let you know.

We need a config.ini for each NMC affected by this issue, rather than email screenshots. You can get that config.ini [via these instructions|http://nam-en.apc.com/app/answers/detail/a_id/9321]. Also, what email server is being used along with the version number. We only test with Microsoft Exchange 2003 I believe. It's noted in the user's guide what we test with if you want to double check.

I also don't think it'd be a bad idea to view this forum thread for a similar issue -> http://forums.apc.com/spaces/11/netbotz-hardware-software/forums/general/6086/netbotz-vs-ap9619

In this scenario, a customer had a similar issue but found a workaround. We found it to be an issue related how the customer's mail server handled our mail and made a fix for a future AOS. Perhaps we are seeing a similar issue here with your set up. I'd suggest that with 5.1.3, try the following steps, after his email test fails the first time after initial configuration:

Go to "Administration | Notification | E-mail | recipients" click on the defined recipient and hit "Apply" (without changing anything!).
I think the above note is worth a try. Then, if available, we need the details on your mail server - name and version. It may also not be a bad idea to see if you can get packet captures between the NMC's and email server, that helped us out greatly in the other thread i sent.

so that we don't duplicate efforts, will you be continuing via email support? i just dont want to have to have us replying in two spots with the same info when i am now involved via email.

P.S. - i have a newer firmware available that you can try if you want or i have AOS 5.0.3/sumx 5.0.3 worst case. i'd hate for you to downgrade because you lose so many features like IPv6, language packs, etc and when you downgrade, you will loose your IP network settings, explained here.

jttallman_apc
Crewman
Crewman
0 Likes
0
405

Re: Email notifications not working since upgrade

This was originally posted on APC forums on 2/3/2011


The firmware versions I have tried so far are:

SUMX 5.0.0 - No UPS tab
SUMX 5.1.1 - Failed email alert
SUMX 5.1.3 - Failed email alert

If you have a 5.2.x version I would gladly try it. Or go back to 5.0.3 which I have not tried.

jttallman_apc
Crewman
Crewman
0 Likes
0
407

Re: Email notifications not working since upgrade

This was originally posted on APC forums on 2/3/2011


Can you send the link to a download. We are unable to get it through email.

BillP
Administrator Administrator
Administrator
0 Likes
0
407

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 2/4/2011


I PMed the link to you via the forum private messaging system. check the envelope on the top right of your forum screen to view my message. i cannot post the link publically.

5.2.x is not available yet. i only have AOS 5.1.5.

voidstar_apc
Janeway
Janeway
0 Likes
0
407

Re: Email notifications not working since upgrade

This was originally posted on APC forums on 1/17/2011


>
If I do a test run it says test sent successfully.
>

And I assume that the test email did not go through?

The most direct way to examine this problem is to put the NMC on a hub, run wireshark on a laptop connected to the hub, and obtain a packet trace of the test email.

BillP
Administrator Administrator
Administrator
0 Likes
0
405

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 1/17/2011


hi,

i suggest reading this thread and testing as much of it as you can -> http://forums.apc.com/spaces/15/universal-transfer-switch/forums/general/3981/sbp5000rmi2u-issue/1#2...

let me know how you make out. i am still investigating the other posters issue but i'd like to see if what he does to fix it, fixes it for you (hitting "Apply" on the recipients screen as he mentions).

also, it may be helpful for you to post your config.ini and event.txt if possible using [these instructions|http://nam-en.apc.com/app/answers/detail/a_id/9321].

thanks.

EDIT - after seeing voidstars post, that is a good idea to try too.

BillP
Administrator Administrator
Administrator
0 Likes
0
407

Re: Email notifications not working since upgrade

This reply was originally posted by george_au on APC forums on 1/18/2011


Yes as I said adove, no errors, but no email ever arrives. Whilst I agree with the wireshark and isolation testing I wont be able to get back to ups for at least 2 weeks in person 😞 Also I read through the other post and tried hitting apply in an attempt to fix it but it made no differnece, however I noticed it mentioned they did recieve an error on the test email sending whereas I dont recieve an error. I downloaded the files via ftp and cheked through the config sections for the smtp server and emails and everything looks ok, the only thing I noticed was that the username for smtpauth is user but that seems to be the default so I assume it means no authentication ??

Message was edited by: jarrod.morrison3@det.nsw.edu.a

BillP
Administrator Administrator
Administrator
0 Likes
0
407

Re: Email notifications not working since upgrade

This reply was originally posted by george_au on APC forums on 1/18/2011


Also with further testing, with the backupexec notifications just to exhaust a few possiblities I usually didnt have authentication turned on, so turned it on with a username of user and no password and the emails went through fine, so its safe to say the email server isnt boucing based on authentication sending a username with a blank password (Email servers are exchange 2007). I also did a factory reset on the network card and only changed the email notification settings and nothing else and still could not get anything through and the most annoying part is I still dont get an error when sending a test email

Message was edited by: jarrod.morrison3@det.nsw.edu.a

BillP
Administrator Administrator
Administrator
0 Likes
0
405

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 1/18/2011


ok so if i understand this correctly, when you enable authentication on your NMC and email server, everything works correctly?

BillP
Administrator Administrator
Administrator
0 Likes
0
407

Re: Email notifications not working since upgrade

This reply was originally posted by george_au on APC forums on 1/18/2011


Nope, my testing with backupexec notifications worked with authentication or without, nmc has still NOT worked at this site at all. I even tried using the ip address temporarily of the server that runs backupexec on the nmc to rule anything strange like that out and it still didnt work (The ips are next to each other anyhow). With the email servers I have no control over them, I just know they run exchange 2007 and usually allow internal messaging without authentication

BillP
Administrator Administrator
Administrator
0 Likes
0
407

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 1/19/2011


hm ok. and you cannot get access to the event log on your mail server at the time of a test email? is that an option?

that may help us out if you cannot do the packet capture for a while. exchange 2003 i know was tested but i don't know about 2007.

BillP
Administrator Administrator
Administrator
0 Likes
0
407

Re: Email notifications not working since upgrade

This reply was originally posted by george_au on APC forums on 1/21/2011


Unfortunately the event logs for the mail servers are definately not going to be provided to me as the mail team has no interest in supporting the notifications as stupid as it sounds, It is strange that I dont actually get a fail message when I send the test email, the event logs on the ups seem clean and I can send a backupexec test email at the same time as the apc management card test and recieve the backupexec one ok. I was hoping to find some kind of solution without needing to go back to the site for the packet capture

BillP
Administrator Administrator
Administrator
0 Likes
0
408

Re: Email notifications not working since upgrade

This reply was originally posted by Angela on APC forums on 1/21/2011


hmm ok. i understand. can you provide me the event.txt and config.ini of your NMC giving you the issue? You can delete any sensitive info out of them if you want. follow [these instructions|http://nam-en.apc.com/app/answers/detail/a_id/9321] to gather them if you want.