Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84713members
354105posts

Can't seem to connect 9617 to apcupsd

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
BillP
Administrator Administrator
Administrator
0 Likes
14
1191

Can't seem to connect 9617 to apcupsd

This question was originally posted by Bill on APC forums on 1/30/2016


I'm running UnRaid and trying to get it to connect to my 9617. The settings look right in the apcupsd  .conf file based on reading the manual, but it just won't connect. ApcTest returns can't connect to socket (38). I ran netstat and I don't see any other resources hogging the port, but I don't see the daemon using the port either I almost think it's an authentication problem, but I reset the Device name and Device password (not user password).

Anyway to test the device name and device password to make sure it's correct? Any other bright ideas?

Thanks

Tags (2)

Accepted Solutions
BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/7/2016


I never could get PowerChute to see my UPS, I assume that was also a password issue. 

See Answer In Context

14 Replies 14
BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 1/30/2016


OK, when i try to log into the Device (not user) I get protected object. Which setting in the interface is causing this?

UnexpectedBill_apc
Captain
Captain
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This was originally posted on APC forums on 1/31/2016


Is the "device" user enabled within the AP9617 preferences?

On SUMX 3.7.2/AOS 3.7.3 this is located under the Administration tab > Security > Local Users > Administrator, Device or Read Only.

Is HTTPS enabled in the management card's configuration interface? (Administration tab > Network > Web > Access)

Another setting to check might be that regarding authentication. (Administration tab > Security > Remote Users)

BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 1/31/2016


On 1/30/2016 8:19 PM, William said:

Is the "device" user enabled within the AP9617 preferences?

Yep

On 1/30/2016 8:19 PM, William said:

On SUMX 3.7.2/AOS 3.7.3 this is located under the Administration tab > Security > Local Users > Administrator, Device or Read Only.

Read Only is enabled, what is this for?

On 1/30/2016 8:19 PM, William said:

Is HTTPS enabled in the management card's configuration interface? (Administration tab > Network > Web > Access)

HTTPS was off, HTTP on. I changed, but it did not make a difference

On 1/30/2016 8:19 PM, William said:

Another setting to check might be that regarding authentication. (Administration tab > Security > Remote Users)

Only local authentication is turned on. I thought this would be OK for the LAN.

I was able to get into the Device through the browser, PowerChute on my PC was blocking it. I was hoping this would solve my UnRaid problem too, but it did not. 😞

Thanks for the help.

BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 1/31/2016


Hi,

Go the the Administration tab - General - Reset/Reboot and Reset All Except TCP/IP to reset the NMC to factory defaults. Then configure APCUPSD to communicate with the card.

BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 1/31/2016


On 1/31/2016 10:00 AM, Bill said:

Go the the Administration tab - General - Reset/Reboot and Reset All Except TCP/IP to reset the NMC to factory defaults. Then configure APCUPSD to communicate with the card.

Tried that twice. 🙂 Updated the firmware too. The status on the card is OK.

I also installed APCUPSD in Windows with the same result. I added my boxes to the client list on the card, switched back to DHCP, added the APC to my hosts file in Windows/Linux. 

I can get into the admin/device with the browser and the console. I can also ping the IP and the friendly name. Going to try pinging (nping) the port next to see if it's being blocked.

Thanks

BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 1/31/2016


apctest returns this:

2016-01-31 13:19:21 apctest 3.14.13 (02 February 2015) slackware

Checking configuration ...
sharenet.type = Network & ShareUPS Disabled
cable.type = Ethernet Link
mode.type = PCNET UPS Driver
Setting up the port ...
apctest FATAL ERROR in apctest.c at line 321
Unable to open UPS device.
If apcupsd or apctest is already running,
please stop it and run this program again.
apctest error termination completed

What is this about? sharenet.type = Network & ShareUPS Disabled

I can't find a setting for it.

apcaccess returns this:

root@TerraByteMe:/etc/apcupsd# apcaccess status
APC : 001,018,0465
DATE : 2016-01-31 13:22:28 -0500
HOSTNAME : TerraByteMe
VERSION : 3.14.13 (02 February 2015) slackware
UPSNAME : TerraByteMe
CABLE : Ethernet Link
DRIVER : PCNET UPS Driver
UPSMODE : Stand Alone
STARTTIME: 2016-01-31 13:22:19 -0500
STATUS : COMMLOST
MBATTCHG : 10 Percent
MINTIMEL : 10 Minutes
MAXTIME : 0 Seconds
NUMXFERS : 0
TONBATT : 0 Seconds
CUMONBATT: 0 Seconds
XOFFBATT : N/A
STATFLAG : 0x05000100
END APC : 2016-01-31 13:23:19 -0500

It does seem to see the UPS, as it shows this: APC : 001,018,0465

Any ideas?

Thx

BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/1/2016


Hi,

Ran a test this morning and was able to get communications established between APCUPSD version 3.14.13 on Windows 7. The NMC was a AP9618 running AOS 3.7.3 and SUMX 3.7.2 Be sure to enter the proper ip address of the NMC, user name, and pass phrase in the config file. The defaults the user name is apc and the pass phrase is admin user phrase. You should also verify UDP port 3052 is open on the system and not blocked on the LAN and that the ip address of the system is registered with the NMC. 

Attachments
BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/3/2016


On 2/1/2016 11:22 AM, Bill said:

user name is apc and the pass phrase is admin user phrase

So my firmware and APCUPSD version are the same as yours, Servers are entered in the NMC client.

The original firmware had Device User, Device Password and Device Pass Phrase. The new firmware only has User and password. I changed both of these and can log into the device user from the browser.

The odd thing is that PowerChute cannot detect the card either, so it looks like a port issue, just strange that it's happening on a Linux Box and a Windows box. That pretty much leaves the router. I guess I'll connect the card to a crossover cable on the laptop and see what happens.

The IP utility by APC does find the card though.

BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/3/2016


Hi,

You should also verify the authentication phrase matches. The default is admin user phrase. If the phrase does not match communications will fail.

In apcupsd.conf be sure 

UPSCABLE ether

UPSTYPE pcnet

DEVICE XXX.XXX.XXX.XXX:apc:admin user phrase

Attachments
BillP
Administrator Administrator
Administrator
0 Likes
0
1191

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/4/2016


I think we have a winner! Thanks.

smile

BillP
Administrator Administrator
Administrator
0 Likes
0
1187

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/4/2016


Still no joy.

Config looks like this:


UPSNAME APC961702

UPSCABLE ether

UPSTYPE pcnet

DEVICE 192.168.1.124:APC9617:################

SCRIPTDIR d:\apcupsd\etc\apcupsd

PWRFAILDIR d:\apcupsd\etc\apcupsd

NOLOGINDIR d:\apcupsd\etc\apcupsd

ONBATTERYDELAY 6

BATTERYLEVEL 5

MINUTES 3

TIMEOUT 240

ANNOY 60

ANNOYDELAY 120

NOLOGON disable

KILLDELAY 0

NETSERVER on

NISIP 0.0.0.0

NISPORT 3551

EVENTSFILE d:\apcupsd\etc\apcupsd\apcupsd.events

EVENTSFILEMAX 10

UPSCLASS standalone

UPSMODE disable

STATTIME 0

STATFILE d:\apcupsd\etc\apcupsd\apcupsd.status

LOGSTATS off

DATATIME 0

#FACILITY DAEMON

#BATTDATE mm/dd/yy

#SENSITIVITY H

#WAKEUP 60

#SLEEP 180

#LOTRANSFER 208

#HITRANSFER 253

#BEEPSTATE T

#LOWBATT 2

#OUTPUTVOLTS 230

#SELFTEST 336

Still getting this:

APCUPSD Tray

Attachments
BillP
Administrator Administrator
Administrator
0 Likes
0
1188

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/4/2016


On 2/3/2016 8:31 AM, Bill said:

DEVICE XXX.XXX.XXX.XXX:apc:admin user phrase

dang, missed this bit. Apparently it ignores the Device name and uses apc no matter what.

Thanks.

BillP
Administrator Administrator
Administrator
0 Likes
0
1188

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Ben on APC forums on 2/6/2016


I had similar issues with 9617 and apcupsd on Mac OS X. Verified using the Powerchute software that username and passphrase matched but still couldn't get apcupsd to work. In the end I've switched to using Powerchute which is actually quite decent in terms of functionality, although I wish it had some kind of menubar monitor. I guess that may not help in your case though.....

BillP
Administrator Administrator
Administrator
0 Likes
0
1192

Re: Can't seem to connect 9617 to apcupsd

This reply was originally posted by Bill on APC forums on 2/7/2016


I never could get PowerChute to see my UPS, I assume that was also a password issue.