Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84710members
354098posts

AP9631 reboots when I try to set Alert settings.

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
jmakowski_apc
Crewman
Crewman
0 Likes
5
236

AP9631 reboots when I try to set Alert settings.

This was originally posted on APC forums on 11/27/2013



I have 2 AP9631's, each in a Smart-UPS RT 3000 XL.  I have many other Smart-UPS RT 3000 XL units with AP9631's in them.  Yet these two (in our Oakland office) are the only ones that do this.

If I try to set Alert settings, either "By Group" or "By Event", the minute I click Apply the AP9631 reboots.  When it comes back up, the Alert(s) I tried to change is(are) back to the original configuration.

It seems odd to me that only these two units would have this issue.  Perhaps it is a problem with the batch these two AP9631's came from?

Has anyone else seen this before?

I am adding the Dump and Debug files from the device.   The Dump lists the cause as a Heap Reset.  I tried reloading the Firmware/Software on one of them but it did not resolve the issue.  The Firmware/Software image is the same exact file installed on the other devices.

They are running:

Application Module
Name:sumx
Version:v6.0.6
Date:Apr  5 2013
Time:11:25:39
APC OS (AOS)
Name:aos
Version:v6.0.6
Date:Apr  5 2013
Time:10:36:37
APC Boot Monitor
Name:bootmon
Version:v1.0.2
Date:Jan 21 2010
Time:13:35:57

This is identical to other units not experiencing this.

Any help is appreciated.

Thanks,

Jim Makowski

Attachments

Accepted Solutions
BillP
Administrator Administrator
Administrator
0 Likes
0
236

Re: AP9631 reboots when I try to set Alert settings.

This reply was originally posted by Angela on APC forums on 2/3/2014


It's likely, if anything, it's a firmware bug. What we are finding is there seems to be a memory issue which could be due to your particular configuration.

If it were me, what I'd suggest we can is a "format" (but that will wipe every single setting on the network management card, including IP settings), so if you can't do that via the format command in telnet/SSH/local console, the next best is to reset to defaults excluding TCP/IP settings so you can still log in and not lose the IP settings. With a minimal configuration, such as JUST your email server/recipient settings, I'd try it again to see if it still does this when you try to change configuration settings. Then, we slowly configure it to see if we can narrow down what in your configuration is possibly causing this. I have done this set up a few times and it does not occur so I don't think it is affecting everyone.

If anything has changed since you gave me this config.ini, you could also back up your config.ini again so once we get this sorted, you have a back up file to load at least.

Let me know if you have any questions prior to moving forward or need clarification. We just need to narrow down the problem area to determine where there is a bug or issue.

See Answer In Context

5 Replies 5
BillP
Administrator Administrator
Administrator
0 Likes
0
236

Re: AP9631 reboots when I try to set Alert settings.

This reply was originally posted by Angela on APC forums on 12/12/2013


I do not see the same TCP/IP stack failure I was expecting to see. I'll need to have someone look at these further and report back. It could still be related to the issue we've seen with the uncached mail server but maybe presenting itself in a different way.

Oh, I forgot - can you get me config.ini's from these units or at least one and one that's working properly? I know you said you had identical units that were not doing this.

jmakowski_apc
Crewman
Crewman
0 Likes
0
236

AP9631 reboots when I try to set Alert settings.

This was originally posted on APC forums on 11/27/2013



I have 2 AP9631's, each in a Smart-UPS RT 3000 XL.  I have many other Smart-UPS RT 3000 XL units with AP9631's in them.  Yet these two (in our Oakland office) are the only ones that do this.

If I try to set Alert settings, either "By Group" or "By Event", the minute I click Apply the AP9631 reboots.  When it comes back up, the Alert(s) I tried to change is(are) back to the original configuration.

It seems odd to me that only these two units would have this issue.  Perhaps it is a problem with the batch these two AP9631's came from?

Has anyone else seen this before?

I am adding the Dump and Debug files from the device.   The Dump lists the cause as a Heap Reset.  I tried reloading the Firmware/Software on one of them but it did not resolve the issue.  The Firmware/Software image is the same exact file installed on the other devices.

They are running:

Application Module
Name:sumx
Version:v6.0.6
Date:Apr  5 2013
Time:11:25:39
APC OS (AOS)
Name:aos
Version:v6.0.6
Date:Apr  5 2013
Time:10:36:37
APC Boot Monitor
Name:bootmon
Version:v1.0.2
Date:Jan 21 2010
Time:13:35:57

This is identical to other units not experiencing this.

Any help is appreciated.

Thanks,

Jim Makowski

BillP
Administrator Administrator
Administrator
0 Likes
0
236

Re: AP9631 reboots when I try to set Alert settings.

This reply was originally posted by Angela on APC forums on 11/27/2013


Can you please give event.txt too?

jmakowski_apc
Crewman
Crewman
0 Likes
0
236

Re: AP9631 reboots when I try to set Alert settings.

This was originally posted on APC forums on 1/31/2014


Here is a config.ini from one of the units in our Cambridge office.

Attachments
BillP
Administrator Administrator
Administrator
0 Likes
0
237

Re: AP9631 reboots when I try to set Alert settings.

This reply was originally posted by Angela on APC forums on 2/3/2014


It's likely, if anything, it's a firmware bug. What we are finding is there seems to be a memory issue which could be due to your particular configuration.

If it were me, what I'd suggest we can is a "format" (but that will wipe every single setting on the network management card, including IP settings), so if you can't do that via the format command in telnet/SSH/local console, the next best is to reset to defaults excluding TCP/IP settings so you can still log in and not lose the IP settings. With a minimal configuration, such as JUST your email server/recipient settings, I'd try it again to see if it still does this when you try to change configuration settings. Then, we slowly configure it to see if we can narrow down what in your configuration is possibly causing this. I have done this set up a few times and it does not occur so I don't think it is affecting everyone.

If anything has changed since you gave me this config.ini, you could also back up your config.ini again so once we get this sorted, you have a back up file to load at least.

Let me know if you have any questions prior to moving forward or need clarification. We just need to narrow down the problem area to determine where there is a bug or issue.