Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84245members
353344posts

AP7920 firmware problems

APC UPS Data Center & Enterprise Solutions Forum

Schneider Electric support forum for our Data Center and Business Power UPS, UPS Accessories, Software, Services, and associated commercial products designed to share knowledge, installation, and configuration.

Solved
imark015_apc
Crewman
Crewman
0 Likes
9
893

AP7920 firmware problems

This was originally posted on APC forums on 3/24/2015


Hi,

I got an AP7920, its loaded with the firmware 3.7.4 and this is loading.

After boot, some times my network settings are gone, and when i try to turn on ( or off ) port 1 for example, port 7 responds and turns off.

This happens with a lot of commands.

I can use com port and ftp. Web interface loads, but also says sometimes this: 

Communication Status
 

Communication has been lost to the device!

and after a reboot the message is gone, but then the ports act weird.

Maybe i can downgrade and look if that helps?

I need a firmware download then.

Thanks in advance,

Mark

Tags (2)

Accepted Solutions
BillP
Administrator Administrator
Administrator
0 Likes
0
894

Re: AP7920 firmware problems

This reply was originally posted by Angela on APC forums on 3/25/2015


Well, the application loads and part of it loading is that it establishes communication and then yours shows immediately lost. I think this is due to a failed connection rather than an "intermittent" communication between management interface and PDU relay boards/intelligence. I think the intermittent connection would cause more lost/established spamming your log.

We don't provide schematics or anything unfortunately so besides opening it up and eyeballing at your own risk to see any obvious connector problems, there is not much to do that I could suggest. We don't service these even ourselves or sell spare parts. The entire unit is just replaced for this type of product.

See Answer In Context

9 Replies 9
Terry_Kennedy_apc
Commander
Commander
0 Likes
0
895

Re: AP7920 firmware problems

This was originally posted on APC forums on 3/25/2015


That's an odd one. There are 3 pieces of firmware involved, the AOS and APP (which is what you upgrade with a firmware update) and the firmware on the relay board (which you can't see directly).

The "communication lost" and the wrong outlet switching would normally indicate a problem on the relay board, but losing the network configuration indicates a problem on the management board. The only thing I could think of (bear in mind I'm just a user, not an APC employee) is that the NVRAM on the management board is having trouble storing the configuration. An incorrect baud rate on the internal port would give you the "communication lost" error. I suppose a power supply problem could also cause this, but these units have redundant power supplies.

I assume it has been running 3.7.4 for some time, and the problem only started happening recently? If you updated the firmware and the problem started happening soon after, I'd suspect a bad firmware load and would suggest retrying the update process. However, the firmware on these is pretty good at detecting when it has become corrupted.

Angela will probably want the event.txt from the device (available via FTP). A copy of the config.ini both before and after the problem happens might also be useful.

If this unit is in warranty, replacing it might be the easiest / fastest solution.

imark015_apc
Crewman
Crewman
0 Likes
0
895

Re: AP7920 firmware problems

This was originally posted on APC forums on 3/25/2015


Hi

I got the pdu from someone who already had trouble with it, so I do not have a config.ini before the problems. I updated the firmware to 3.7.4, and then it got even worse. 

It is also turning on and off random ports at random times, and the number display shows nothing, it is off.

imark015_apc
Crewman
Crewman
0 Likes
0
885

Re: AP7920 firmware problems

This was originally posted on APC forums on 3/25/2015


This is the about screen:

About System

Model Number : AP7920
Serial Number : ZA0525014021
NMC Serial Number : ZA0525007101
Manufacture Date : 06/16/2005
Hardware Revision : B2
MAC Address : 00 C0 B7 77 1C D3
Flash Type : TOS TC58FVM5B2

Press to continue...

-----------------------------------------------------------------------
Module Information

Description : Rack PDU APP
-----------------------------------------------------------------------
Name : rpdu Type : StatApp
Version : 374 Sector : 16
Date : 03/13/2012 Time : 16:16:54
CRC16 : 4D49

Press to continue...

Description : Network Management Card AOS
-----------------------------------------------------------------------
Name : aos Type : APC OS
Version : 374 Sector : 47
Date : 11/09/2011 Time : 11:45:09
CRC16 : 49C6

The display now shows 88, and i tried to turn on port 1, and port one stayed off, and 2 to 8 turned on.. 

Nothing is connected.

imark015_apc
Crewman
Crewman
0 Likes
0
895

Re: AP7920 firmware problems

This was originally posted on APC forums on 3/25/2015


Discovered something. There is NO config.ini ! 

and now i see this.


Description : Network Management Card AOS
-----------------------------------------------------------------------
Name : aos Type : APC OS
Version : 374 Sector : 16
Date : 11/09/2011 Time : 11:45:09
CRC16 : 49C6

Press to continue...

Description : Network Management Card AOS
-----------------------------------------------------------------------
Name : aos Type : APC OS
Version : 374 Sector : 47
Date : 11/09/2011 Time : 11:45:09
CRC16 : 49C6

2 AOS.

BillP
Administrator Administrator
Administrator
0 Likes
0
895

Re: AP7920 firmware problems

This reply was originally posted by Angela on APC forums on 3/25/2015


This device is about 10 years old. When you had the correct firmware on it, it sounded like the problem was the network management interface couldn't talk to the relay boards which can happen over time if the connector is damaged or has failed due to age.

With this latest information where you have two AOS, you need to get the apc_hw02_rpdu_374.bin file (which it sounds like you have since it would've been in the .exe you downloaded) and go ahead and FTP that to the Rack PDU and it should be fine afterwards - in the sense of proper firmware being loaded. When you do that, I'd want to see the event log.

Instructions on fixing firmware/manual FTP are here -> http://www.apc.com/support/index?page=content&country=ITB〈=en&locale=en_US&id=FA156047 

Instructions on downloading logs -> http://www.apc.com/support/index?page=content&country=ITB〈=en&locale=en_US&id=FA156131

imark015_apc
Crewman
Crewman
0 Likes
0
885

Re: AP7920 firmware problems

This was originally posted on APC forums on 3/25/2015


Hi, i also noticed the rpdu file was gone, so i put it back a few moments ago, but now my serial connection doesnt work anymore, so i cannot logon. it responds to ping, and the telnet window closes randomly.

And a few seconds ago it randomly reboots and it turned all ports on. 

display is still off.

following Abouts:


-----------------------------------------------------------------------
About System

Model Number : AP7920
Serial Number : ZA0525014021
NMC Serial Number : ZA0525007101
Manufacture Date : 06/16/2005
Hardware Revision : B2
MAC Address : 00 C0 B7 77 1C D3
Flash Type : TOS TC58FVM5B2

Press to continue...

-----------------------------------------------------------------------
Module Information

Description : Rack PDU APP
-----------------------------------------------------------------------
Name : rpdu Type : StatApp
Version : 374 Sector : 16
Date : 03/13/2012 Time : 16:16:54
CRC16 : 4D49

Press to continue...

Description : Network Management Card AOS
-----------------------------------------------------------------------
Name : aos Type : APC OS
Version : 374 Sector : 47
Date : 11/09/2011 Time : 11:45:09
CRC16 : 49C6

I am downloading the logs now.

I also noticed config.ini is there now.

BillP
Administrator Administrator
Administrator
0 Likes
0
895

Re: AP7920 firmware problems

This reply was originally posted by Angela on APC forums on 3/25/2015


Thanks. Yes, you will only see the log files for the most part, definitely config.ini and data.txt, if you have APP file loaded (rpdu in this example).

The event log looks pretty normal but... 

Switched Rack PDU: Communications lost.	0x0F08

I expected to see a log full of communications lost/established but it is fairly infrequent and just a persistent lost communication problem. Even so, when you see this frequently or when it is persistent, what I said earlier is true - the management interface cannot talk to the outlet relays and the outlet relays are energized/controlled by the management interface. I see it as one of the more recent events at the top of the log and this isn't good. When there is a communication loss between the two components, then the outlets can be unpredictable. Also, their "normal" state is open/off and not passing power.

You'll likely have unpredictable outlet control with this issue and we'd generally recommend a replacement for this issue since these aren't field serviceable.

imark015_apc
Crewman
Crewman
0 Likes
0
895

Re: AP7920 firmware problems

This was originally posted on APC forums on 3/25/2015


This log file is downloaded a few seconds after the installation of the application, so that could mean why the log file doesnt show it that often?

Is there any other way i might get it fixed?

I dont mind spending a lot of time on it.

BillP
Administrator Administrator
Administrator
0 Likes
0
895

Re: AP7920 firmware problems

This reply was originally posted by Angela on APC forums on 3/25/2015


Well, the application loads and part of it loading is that it establishes communication and then yours shows immediately lost. I think this is due to a failed connection rather than an "intermittent" communication between management interface and PDU relay boards/intelligence. I think the intermittent connection would cause more lost/established spamming your log.

We don't provide schematics or anything unfortunately so besides opening it up and eyeballing at your own risk to see any obvious connector problems, there is not much to do that I could suggest. We don't service these even ourselves or sell spare parts. The entire unit is just replaced for this type of product.