Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

Close
Important Announcement: WELCOME to the Schneider Electric Community! We have moved to a new address: community.se.com — bookmark it today and contact SchneiderCommunity.Support@se.com if you have any questions!
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
82691members
350410posts

Machine Thumbprint Changed and License not working

SmartConnector Forum

Discussion of SmartConnector applications for integration of various other building management systems (BMS) into EcoStruxure Building Operation

SteveGregory
Commander Commander
Commander
0 Likes
2
157

Machine Thumbprint Changed and License not working

We have SmartConnector running on a customer's VM and the Machine Thumbprint seems to  have Changed and the License  is no longer valid. We can re-generate the core license but need to go to the developer to get the processor license changed which will take some time. Does anyone know why this might happen?

2 Replies 2
Nick-Iebba
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
0
153

Re: Machine Thumbprint Changed and License not working

Hmm, I have not experienced this issue before and I am not sure why this occurs. Perhaps @JeffBowman could shed some light on it.

JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
0
150

Re: Machine Thumbprint Changed and License not working

Hi Steve,

 

There have been some reports (about 3, including yours) lately of the machine thumbprint changing on a PC reboot... I have no idea what could be causing this! All these reports have come in the past few weeks, so I am wondering if there was some windows update that is causing this issue.. The machine thumbprint is a hash of the MAC Address(s) on the machine, as well as the serial number of the motherboard.

I don't believe the MAC addresses are the issue here as when we check the thumbprint we are actually generating every possible thumbprint with each MAC address to make sure we are valid if the active MAC address changes. So I am thinking there is something weird going on with the serial number of the Motherboard on reboot..

I checked the source code, and we don't add anything to the log when we create the thumbprint (probably for security purposes.. so it would be difficult to debug this in the field, to see if there is something wrong with the Serial number/ MAC address that could be causing the thumbprint to change.

 

That said, I would be happy to create a incremental build with some logging added, if you would be willing to install it and help me run some tests (I haven't been able to reproduce this defect locally on any of my machines).

 

Best Regards,

 

-Jeff