Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

Close
Important Announcement: WELCOME to the new Schneider Electric Community! Community is now no longer part of Exchange, and is now rebranded under se.com. If you have any bookmarks and links saved, we request you to update them to ensure that you continue accessing our community from this new location. For any issues that you might encounter as part of this change, please reach out to SchneiderCommunity.Support@se.com, and the team will help to get your issues resolved.
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
82514members
350118posts

EWS Server History Values in SmartConnector are showing incorrect value in EBO

SmartConnector Forum

Discussion of SmartConnector applications for integration of various other building management systems (BMS) into EcoStruxure Building Operation

SteveGregory
Commander Commander
Commander
0 Likes
4
553

EWS Server History Values in SmartConnector are showing incorrect value in EBO

I have a SmartConnector extension running in 2.5.4 with boolean type History records which appear correct when viewed in the SmartConnector portal, however; they are all reading 0 in EBO 4.0.1.86. See attached screen shot. 

Attachments
Tags (2)
4 Replies 4
ardak
Commander Commander
Commander

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Steven,

 

I've tested this and it looks like there's an issue with boolean serialization. It will be looked at ASAP.

 

BR

Armend

Tags (1)
SteveGregory
Commander Commander
Commander
0 Likes
2
372

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Just wondering if there is any update on this issue?

Tags (1)
ardak
Commander Commander
Commander
0 Likes
1
366

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Steve,

 

There's an issue in EBO where EBO's EWS client doesn't understand boolean trends from Smartconnector. I just got word that this will be fixed in 4.0.3. 

 

I'll probably add a "legacy serve" mode to Smartconnector that can be turned on to allow older EBO clients to be used. 

 

BR

Armend

Tags (1)
SteveGregory
Commander Commander
Commander
0 Likes
0
352

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Ardak,

Thanks for the update. If you have a version with this fix, happy to try it out. 

Steve

Tags (1)