Issue
A customer needs to upgrade a legacy Automation Server (AS) to an Automation Server Premium (AS-P). When attempting the upgrade using PCT, the process fails with the following error:
"Upgrade failed"
What is the best way of doing the upgrade?
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Automation Server Premium(AS-P)
- Building Operation Classic Automation Server (AS)
Cause
Classic Automation Server backups cannot be upgraded directly to an AS-P. The backup must first be converted to an AS-P backup format before the upgrade can be completed.
Resolution
When converting a Classic AS backup it is better to use Device Administrator(DA) as the AS will be converted to an AS-P backup and upgraded to the version of DA at the same time.
- Open Device Administrator for the target version.
- Open the function "Convert backup set server type"
- Browse to the AS backup in "Backup set to convert" and click "Convert"
- The backup is converted to an AS-P and upgraded to the target version, the converted backup and be found in "Converted backup set output path" location.
Refer to the EBO Webhelp Convert Backup Set Server Type Dialog Box for further information.