Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84607members
353884posts

BR900GI battery charge status icon blinking.

APC UPS for Home and Office Forum

Schneider Electric support forum for our APC offers including Home Office UPS, Surge Protectors, UTS, software and services and associated products designed to share knowledge, installation, and configuration.

Solved
efebingol_apc
Cadet
0 Likes
2
173

BR900GI battery charge status icon blinking.

This was originally posted on APC forums on 2/10/2015


Hi,

I have a BR900GI, it was not used for like 2 months and it is not in guarantee. 

As I attached it to wall outlet for couple of hours, the "empty" battery charge status icon (not the replace battery icon) is blinking and it seems like it is not charging/detecting the battery. I tired to attach it without the batteries, it is the same situation.

It was working OK 2 months ago...

Is this a problem with the unit or if I replace the batteries it will work without problem?.

Thank you in advance.

Tags (3)

Accepted Solutions
vinodg_apc
Crewman
Crewman
0 Likes
0
173

Re: BR900GI battery charge status icon blinking.

This was originally posted on APC forums on 12/25/2016


Dear Angela

i had made a post on the SUA5000RMI5U ups two days back.  No one responded to me on this.  The UPS was not turning on and when consulted with our supplier they said that the battery might be down and it needs to replaced.  We replaced the battery.  After connecting new battery, the UPS Started.  But after self test the battery discharge/disconnect light was flashing and no lights in battery charge led.  I left the UPS to run like this and today i found that the battery was showing full charge and in between, the battery discharge light flashes for a minute and then the battery charge light comes in.  I disconnected the input power to see if the UPS will work on battery.  But it didnt.  All the instruments connected to UPS went off.  When the input current was given the battery charge lights shows only on led flashing and after sometime it is showing steady.  May be its charging.  Is there any settings we have to do it with the software.  I installed powerchute but when i connect a USB -RS232 cable to the UPS the UPS shuts down.  the UPS have a smart slot as well.    The UPS is almost 5 years old.  it was not used for almost a year and we restarted it now.  Can you please advice.

Regards

vinod

See Answer In Context

Tags (2)
2 Replies 2
BillP
Administrator Administrator
Administrator
0 Likes
0
173

Re: BR900GI battery charge status icon blinking.

This reply was originally posted by Angela on APC forums on 2/11/2015


Hi - when the unit was not in use, was the battery connected? If so, the battery may have discharged and now cannot charge up. How old is the battery/UPS?

I would also consider letting it charge for at least 24 hours. Flashing battery icon means low battery I believe so I would give it at least 24 hours and check it afterwards. If it still is flashing, then it is possible you may need a new battery if it was left stored connected to the UPS and was older to begin with so now it is discharged and cannot hold a strong charge any more.

vinodg_apc
Crewman
Crewman
0 Likes
0
174

Re: BR900GI battery charge status icon blinking.

This was originally posted on APC forums on 12/25/2016


Dear Angela

i had made a post on the SUA5000RMI5U ups two days back.  No one responded to me on this.  The UPS was not turning on and when consulted with our supplier they said that the battery might be down and it needs to replaced.  We replaced the battery.  After connecting new battery, the UPS Started.  But after self test the battery discharge/disconnect light was flashing and no lights in battery charge led.  I left the UPS to run like this and today i found that the battery was showing full charge and in between, the battery discharge light flashes for a minute and then the battery charge light comes in.  I disconnected the input power to see if the UPS will work on battery.  But it didnt.  All the instruments connected to UPS went off.  When the input current was given the battery charge lights shows only on led flashing and after sometime it is showing steady.  May be its charging.  Is there any settings we have to do it with the software.  I installed powerchute but when i connect a USB -RS232 cable to the UPS the UPS shuts down.  the UPS have a smart slot as well.    The UPS is almost 5 years old.  it was not used for almost a year and we restarted it now.  Can you please advice.

Regards

vinod

Tags (2)